MAXEYE DVB-T2 Signal Analysis Toolkit Help

The MAXEYE DVB-T2 Signal analysis toolkit contains LabVIEW VIs to perform measurements on DVB-T2 signals that confirm ETSI standard EN 302755 version 1.3.1. Refer to the ETSI EN 302755 standard for the signal specifications and this document assumes that the user is familiar with the DVB-T2 standard specification. This document has information about the toolkit Labview API VIs to help engineers for programming.

____________________________________________________________________________________________________

For more information regarding this help please contact info@maxeyetech.com


MaxEye DVB-T2 SA Initialize.vi

This VI creates MaxEye DVB-T2 Signal Analysis Handle with the default values and passes the handle to the later VIs.

Analysis Handle Name specifies the name of the notifier that you want to obtain or create. The default is DVB-T2 to create DVB-T2 Signal Analysis Handle

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

MAXEYE TECHNOLOGIES Private Limited
Digital Video Toolkits - DVB-T2 Signal Analysis

For more details on this help, please write to us at
info@maxeyetech.com


MaxEye DVB-T2 RFSA Configure Hardware.vi

Configures the following properties in the NI RFSA hardware,

1. For Demodulation Measurements

i. Configures the NI RFSA Acquisition Type to IQ or Spectrum Mode based on the measurement mode value configured by the user.
ii. Configures the NI RFSA Number of Records property to Number of Averages value configured by the user.
iii. Configures Number of Records Is Finite to TRUE.
iv. Configures the NI RFSA IQ Rate property to the reciprocal of the elementary period. The tool kit internally computes the elementary period based on the Bandwidth value configured by the user.
v. Configures the NI RFSA trigger settings based on the PreTrigger Delay and Minimum Quite Time values.
vi. Configures the NI RFSA Number of Samples property based on the Acquisition Length and IQ Rate.

2. Spectral Measurements

i. Configures the NI RFSA Acquisition Type to IQ or Spectrum Mode based on the measurement mode value configured by the user.
ii. Configures the NI RFSA Power Spectrum Units property to Volts Squared.
iii. Configures the NI RFSA Number of Averages property to Number of Averages value.
iv. Configures the NI RFSA Averaging Mode property to Averaging Mode value.

instrument handle identifies your instrument session. instrument handle is obtained niRFSA Initialize VI.

DVBT2 Analyzer Params

error in The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

instrument handle out passes a reference to your instrument session to the next VI.

DVBT2 Analyzer Params

number of samples specifies the Number of Samples acquired based on the Acquisition Length and IQ Rate. This value is valid only if the Measurement Mode is set to Demodulation Measurements.

error out The error out cluster passes error or warning information out of a VI to be used by other VIs.


MaxEye DVB-T2 RFSA Measure.vi

This VI perfoms the following.

i. Checks the configuration parameters in the DVB-T2 Signal Analysis handle and returns an error if the configuration is not valid.
ii. Configures the NI RFSA properties based on the user configuration. For more details refer MaxEye DVBT2 RFSA Configure Hardware.vi documentation.
iii. Initiates the Acquisition by calling niRFSA Initiate.vi.
iv. Based on the measurement mode configured by the user, either niRFSA Fetch IQ.vi or niRFSA Read Power Spectrum.vi is used for acquiring the signal.
v. Performs Demodulation Measurements or Spectral Measurements based on the Measurement Mode.

instrument handle identifies your instrument session. instrument handle is obtained niRFSA Initialize VI.

DVB-T2 Signal Analysis handle

timeout (sec) specifies the time to wait, in seconds, before returning an error if the requested number of samples have not been acquired.

A negative value indicates to the driver to wait indefinitely.

error in The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

instrument handle out passes a reference to your instrument session to the next VI.

DVB-T2 Signal Analysis handle

error out The error out cluster passes error or warning information out of a VI to be used by other VIs.


MaxEye DVB-T2 USRP Measure.vi

This VI perfoms the following.

i. Checks the configuration parameters in the DVB-T2 Signal Analysis handle and returns an error if the configuration is not valid.
ii. Initiates the Acquisition by calling niUSRP Initiate.vi.
iv. The signal is acquired using niUSRP Fetch Rx Data.vi.
v. Performs Demodulation Measurements or Spectral Measurements based on the Measurement Mode.

session handle identifies your instrument session. session handle is obtained from the niUSRP Open Rx Session VI and identifies a particular Rx session.

DVB-T2 Signal Analysis Handle In

timeout (sec) specifies the time to wait, in seconds, before returning an error if the requested number of samples have not been acquired.

A negative value indicates to the driver to wait indefinitely.

IQ Rate S/s specifies the rate at which the signal is sampled.

error in The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

session handle passes a reference to your instrument session to the next VI.

DVB-T2 Signal Analysis Handle Out

error out The error out cluster passes error or warning information out of a VI to be used by other VIs.


MaxEye DVB-T2 SA Measure.vi

This VI perfoms the following.

i. Checks the configuration parameters in the DVB-T2 Signal Analysis handle and returns an error if the configuration is not valid.
ii. Performs Demodulation Measurements on the acquired signal.

DVB-T2 Signal Analysis Handle In

Complex Waveform Specifies the data for a real waveform including the start, delta, and actual values.

error in (no error) error in can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

Right-click the error in control on the front panel and select Explain Error or Explain Warning from the shortcut menu for more information about the error.

DVB-T2 Signal Analysis Handle Out

error out error out passes error or warning information out of a VI to be used by other VIs.

Right-click the error out indicator on the front panel and select Explain Error or Explain Warning from the shortcut menu for more information about the error.


MaxEye DVB-T2 SA Close Handle.vi

Closes the DVB-T2 Signal Analysis handle and resources associated with it.

DVB-T2 Signal Analysis Handle

error in (no error) error in can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

Right-click the error in control on the front panel and select Explain Error or Explain Warning from the shortcut menu for more information about the error.

error out error out passes error or warning information out of a VI to be used by other VIs.

Right-click the error out indicator on the front panel and select Explain Error or Explain Warning from the shortcut menu for more information about the error.


MaxEye DVB-T2 SA Set T2 Bandwidth.vi

Configures the value for signal bandwidth property, in Hz in the DVB-T2 Signal Analysis handle. The signal bandwidth determines the IFFT sampling frequency and IQ rate of the generated complex waveform.

DVB-T2 Signal Analysis Handle In

Bandwidth specifies DVB-T2 signal bandwidth. The valid enum values for the signal bandwidth are,
0 --> 1.7 MHz,
1 --> 5MHz,
2 --> 6MHz
3 --> 7MHz.
4 --> 8MHz,
5 --> 10MHz

The default value is 4 (8MHz).

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set Measurement Mode.vi

Configures the Measurement Mode property of the DVB-T2 Signal Analysis handle.

The valid enum values of Measurement Mode are
0 (Demodulation Measurements)
1 (Spectral Measurements)

DVB-T2 Signal Analysis Handle In

Measurement Mode specifies the type of measurement performed on the acquired signal.

The valid enum values of Measurement Mode are
0 (Demodulation Measurements)
1 (Spectral Measurements)

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set Number of Averages.vi

Configures the Number of Averages property of the DVB-T2 Signal Analysis handle. The measurement results are averaged over the number specified by Number of Averages.

DVB-T2 Signal Analysis Handle In

Number of Averages specifies the Number of Averages. The measurement results are averaged over the number specified by Number of Averages.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set Acquisition Length.vi

Sets the Acquisition Length property of the DVB-T2 Signal Analysis handle. The toolkit reads the number of samples equivalent to the Acquisition Length. The minimum Acquisition Length in seconds should be equal to atleast one frame plus the Measurement Number of Symbols.

DVB-T2 Signal Analysis Handle In

Acquisition Length, sec specifies the Acqusition Length in seconds.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set Minimum Quite Time.vi

Configures the Minimum Quite Time property of the DVB-T2 Signal Analysis handle. This value specifies the minimum time below the trigger value during which the signal must remain off, in order to trigger.

DVB-T2 Signal Analysis Handle In

Minimum Quite Time, sec specifies the minimum time below the trigger value during which the signal must remain off, in order to trigger.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set PreTrigger Delay.vi

Configure the PreTrigger Delay property of the DVB-T2 Signal Analysis handle.

DVB-T2 Signal Analysis Handle In

PreTrigger Delay, sec specifies the PreTrigger Delay in seconds.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set Channel Estimation Enabled.vi

Configures the Channel Estimation Enabled property of the DVB-T2 Signal Analysis handle. The valid enum values for this property is 0 (FALSE) or 1 (TRUE).

DVB-T2 Signal Analysis Handle In

Channel Estimation Enabled? specifies whether the channel estimation is enabled or not. The valid enum values for this property is 0 (FALSE) or 1 (TRUE). The default value is 1 (TRUE).

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set CIR Measurements Enabled.vi

Configures the CIR Measurements Enabled property of the DVB-T2 Signal Analysis handle. If this property is set to 1 (Enabled), then the toolkit does Channel Impulse Response (CIR) related measurements. The measurements include Channel Impulse Response Trace, Path Delay, Path Relative Power and Path Absolute Power

The valid enum values for this property is 0 (Disabled) or 1 (Enabled). The default value is 1 (Enabled).

DVB-T2 Signal Analysis Handle In

CIR Measurements Enabled? specifies whether the channel estimation is enabled or not. The valid enum values for this property is 0 (FALSE) or 1 (TRUE). The default value is 1 (TRUE).

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set PLP Index.vi

Configures the PLP Index property of the DVB-T2 Signal Analysis Handle. This property specifies the PLP index for which the tool kit performs the Measurements.

DVB-T2 Signal Analysis Handle In

PLP Index specifies the PLP Index.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set Path Detection Threshold.vi

Configures the Path Detection Threshold property of the DVB-T Signal Analysis Handle. This property specifies the threshold relative to the peak power to detect the number of paths from the channel impulse response trace.
The toolkit detects the number of peaks in the channel response trace above this threshold level.

The default value is -40dB.

DVB-T2 Signal Analysis Handle In

Path Detection Threshold, dB specifies the Path Detection Threshold. This property specifies the threshold relative to the peak power to detect the number of paths from the channel impulse response trace.
The default value is -40dB.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set FFT Window Type.vi

Configures the FFT Window Type property of the DVB-T2 Signal Analysis handle. FFT Window Type is the time-domain window to apply to the time signal.

The valid enum values of FFT Window Types are,
0 (Rectangle)
1 (Hanning (default))
2 (Hamming)
3 (Blackman-Harris)
4 (Exact Blackman)
5 (Blackman)
6 (Flat Top)
7 (4 Term B-Harris)
8 (7 Term B-Harris)
9 (Low Sidelobe)
11 (Blackman Nutall)
30 (Triangle)
31 (Bartlett-Hanning)
32 (Bohman)
33 (Parzen)
34 (Welch)
60 (Kaiser)
61 (Dolph-Chebyshev)
62 (Gaussian)

DVB-T2 Signal Analysis Handle In

FFT Window Type window is the time-domain window to apply to the time signal. The default window is Hanning.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set Center Channel Frequency.vi

Configures the Center Channel Frequency property of the DVB-T2 Signal Analysis handle.

DVB-T2 Signal Analysis Handle In

Center Channel Frequency specifies the center channel frequency in Hz.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set Center Channel Bandwidth.vi

Configures the Center Channel Bandwidth property of the DVB-T2 Signal Analysis handle.

Specifies the frequency range for each channel, in Hz

DVB-T2 Signal Analysis Handle In

Center Channel Bandwidth (Hz) specifies the frequency range for each channel, in Hz.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set ACP Frequency Offsets.vi

Configures the Adjacent Channel Frequency Offsets property of the DVB-T2 Signal Analysis handle, in Hz

Adjacent Channel Frequency Offsets specifies the distance from the center frequency of the main channel to the center frequency of the adjacent channels.

DVB-T2 Signal Analysis Handle In

ACP Frequency Offsets (Hz) specifies the distance from the center frequency of the main channel to the center frequency of the adjacent channels.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set ACP Bandwidths.vi

Configures the Adjacent Channel Bandwidths property of the DVB-T2 Signal Analysis handle.

Adjacent Channel Bandwidth specifies the frequency range of each channel, in Hz.

DVB-T2 Signal Analysis Handle In

ACP Bandwidths (Hz) specifies the frequency range of each channel, in Hz.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set SEM Frequency Offsets.vi

Configures the Spectral Emission Mask (SEM) Frequency Offsets property of the DVB-T2 Signal Analysis Handle. The SEM Frequency Offsets specifies the offset in Hz from the center frequency.

The toolkit uses this property along with the SEM Power Offsets property to create the Spectral Emission Mask.

DVB-T2 Signal Analysis Handle In

SEM Frequency Offsets (Hz) specifies the offset in Hz from the center frequency.
The toolkit uses this property along with the SEM Power Offsets property to create the Spectral Emission Mask.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set SEM Power Offsets.vi

Configures the Spectral Emission Mask (SEM) Power Offset property of the DVB-T2 Signal Analysis handle in dB. The Power Offset levels corresponds to the each frequency offset points specified by SEM Frequency Offsets Property. The Power Offset is relative to the power level specified by the SEM Reference Power Level Type property.

The toolkit uses this property along with SEM Frequency Offsets Property to create the Spectral Emission Mask.

DVB-T2 Signal Analysis Handle In

SEM Power Offsets (dB) specifies the Spectral Emission Mask (SEM) Power Offset. The Power Offset levels corresponds to the each frequency offset points specified by SEM Frequency Offsets Property. The Power Offset is relative to the power level specified by the SEM Reference Power Level Type property.

The toolkit uses this property along with SEM Frequency Offsets Property to create the Spectral Emission Mask.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set SEM Reference Level Type.vi

Configures the Spectral Emission Mask (SEM) Reference Level Type property of the DVB-T2 Signal Analysis handle.

The toolkit uses this property to compute the Spectral Emission Mask.

The valid enum values are
0 (Peak Power)
1 (Total Channel Power)
2 (User Defined Power Level)

DVB-T2 Signal Analysis Handle In

SEM Reference Level Type specifies the Spectral Emission Mask (SEM) Reference Level Type The toolkit uses this property to create the Spectral Emission Mask.

The valid enum values are
0 (Peak Power)
1 (Total Channel Power)
2 (User Defined Power Level)

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set SEM Reference Power Level.vi

Configures the Spectral Emission Mask (SEM) Reference Power Level property in dBm, of the DVB-T2 signal Analysis handle. The toolkit uses this property when the SEM Reference Level Type property is set to User Defined Power Level.

The SEM Reference Power Level and SEM Power Offsets are used to compute the the absolute power levels for each SEM frequency offset points.
The toolkit uses this property to create the Spectral Emission Mask.

DVB-T2 Signal Analysis Handle In

SEM Reference Power Level specifies the Spectral Emission Mask (SEM) Reference Power Level property in dBm. The toolkit uses this property when the SEM Reference Level Type property is set to User Defined Power Level.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set Averaging Mode.vi

Configures the Averaging Mode property of the DVB-T2 Signal Analysis handle. The Averaging mode specifies the type of averaging method used for spectral acquisition. This property is applicable only if the Measurement Mode is Spectral Measurements.

The valid enum values for Averaging mode are
0 (No Averaging)
1 (Vector Averaging)
2 (RMS Averaging)
3 (Peak Hold)

DVB-T2 Signal Analysis Handle In

Averaging Mode averaging mode specifies the averaging mode.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Set Weighting Mode.vi

Configures the Weighting mode property of the DVB-T2 Signal analysis handle. This property is applicable only if the Measurement Mode is Spectral Measurements.

The valid enum values are
0 (Linear)
1 (Exponential)
This property is applicable only for Spectral Measurements.

DVB-T2 Signal Analysis Handle In

Weighting Mode weighting mode specifies the weighting mode for RMS and vector averaging.

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get FFT Size.vi

Returns the FFT Size of the acquired DVB-T2 Signal. \
The allowed values are, 1K, 2K, 4K, 8K, 16K, 32K.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

FFT Size Specifies the FFT Size of the acquired DVB-T2 Signal.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Frequency Offset.vi

Returns the average Frequency Offset in Hz. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Frequency offset, Hz specifies the average Frequency Offset in Hz. The measured Frequency offset is averaged over the number of acquisitions specified by the Number of Averages value.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Clock Offset.vi

Returns the Clock Offset measured in PPM. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Clock Offset (PPM) specifies the Clock Offset measured in PPM.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get RMS EVM in dB.vi

Returns the measured RMS Error Vector Magnitude (EVM) in dB. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

For more details refer section Annex C of Digital Video Broadcasting (DVB); Measurement guidelines for DVB systems (ETSI TR 101 290 V1.2.1 (2001-05))

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

RMS EVM, dB specifies the measured RMS Error Vector Magnitude (EVM) in dB.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get RMS EVM in percentage.vi

Returns the measured RMS Error Vector Magnitude (EVM) in percentage. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

For more details refer section Annex C of Digital Video Broadcasting (DVB); Measurement guidelines for DVB systems (ETSI TR 101 290 V1.2.1 (2001-05))

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

RMS EVM, % specifies the RMS Error Vector Magnitude(EVM) in percentage.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get MER (dB).vi

Returns the measured Modulation Error Ratio (MER) in dB. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

For more details refer section 6.9.2 of Digital Video Broadcasting (DVB); Measurement guidelines for DVB systems (ETSI TR 101 290 V1.2.1 (2001-05))

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Data MER, dB specifies the measured Modulation Error Ratio (MER) in dB.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Peak EVM in dB.vi

Returns the measured Peak Error Vector Magnitude (EVM) in dB. The ratio of error vector to the ideal symbol vector for a particular symbol and subcarrier gives the instantaneous EVM. Peak EVM is the maximum EVM across all symbols and subcarriers. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Peak EVM, dB specifies the measured Peak Error Vector Magnitude (EVM) in dB. The ratio of error vector to the ideal symbol vector for a particular symbol and subcarrier gives the instantaneous EVM. Peak EVM is the maximum EVM across all symbols.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Peak EVM in percentage.vi

Returns the measured Peak Error Vector Magnitude (EVM) in percentage. The ratio of error vector to the ideal symbol vector for a particular symbol and subcarrier gives the instantaneous EVM. Peak EVM is the maximum EVM across all symbols and subcarriers. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Peak EVM, % specifies the measured Peak Error Vector Magnitude (EVM) in percentage. Peak EVM is the maximum EVM across all symbols.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Peak MER (dB).vi

Returns the measured Peak Modulation Error Ratio (MER) in dB. The ratio of ideal symbol vector to error vector for a particular symbol and subcarrier gives the instantaneous MER. Peak MER is the maximum MER across all symbols and subcarriers. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Peak MER, dB specifies the measured Peak Modulation Error Ratio (MER) in dB. The ratio of ideal symbol vector to error vector for a particular symbol and subcarrier gives the instantaneous MER. Peak MER is the maximum MER across all symbols and subcarriers.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Peak EVM Symbol Position.vi

Returns the symbol number corresponding to the Peak Error Vector Magnitude (EVM).
This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Peak EVM Symbol Position specifies the symbol number corresponding to the Peak Error Vector Magnitude (EVM).

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Magnitude Error.vi

Returns the measured Magnitude Error, in dB. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Data Magnitude Error, dB specifies the measured Magnitude Error, in dB.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Phase Error (deg).vi

Returns the measured Phase Error in degrees. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Data Phase Error, deg specifies the measured RMS Phase Error in degrees.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Post Data EVM in dB.vi

Returns the measured RMS Error Vector Magnitude (EVM) in dB of L1 Post Signalling Data. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

For more details refer section Annex C of Digital Video Broadcasting (DVB); Measurement guidelines for DVB systems (ETSI TR 101 290 V1.2.1 (2001-05))

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Post Data EVM, dB specifies the measured L1 Post Data Error Vector Magnitude (EVM) in dB.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Post Data EVM in percentage.vi

Returns the measured RMS Error Vector Magnitude (EVM) in percentage of L1 Post Signalling Data. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

For more details refer section Annex C of Digital Video Broadcasting (DVB); Measurement guidelines for DVB systems (ETSI TR 101 290 V1.2.1 (2001-05))

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Post Data EVM, % specifies the measured L1 Post Data Error Vector Magnitude (EVM) in percentage.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Post Data MER (dB).vi

Returns the measured Modulation Error Ratio (MER) in dB of L1 Post Signalling Data. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

For more details refer section 6.9.2 of Digital Video Broadcasting (DVB); Measurement guidelines for DVB systems (ETSI TR 101 290 V1.2.1 (2001-05))

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Post Data MER, dB specifies the measured L1 Post Data Modulation Error Ratio (MER) in dB.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Post Data Peak EVM in dB.vi

Returns the measured Peak Error Vector Magnitude (EVM) in dB of L1 Post Signalling Data. The ratio of error vector to the ideal symbol vector for a particular symbol and subcarrier gives the instantaneous EVM. Peak EVM is the maximum EVM across all symbols and subcarriers. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Post Data Peak EVM, dB specifies the measured Peak Error Vector Magnitude (EVM) in dB. The ratio of error vector to the ideal symbol vector for a particular symbol gives the instantaneous EVM. Peak EVM is the maximum EVM across all L1 Post Data symbols.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Post Data Peak EVM in percentage.vi

Returns the measured Peak Error Vector Magnitude (EVM) in percentage of L1 Post Signalling Data. The ratio of error vector to the ideal symbol vector for a particular symbol and subcarrier gives the instantaneous EVM. Peak EVM is the maximum EVM across all symbols. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Post Data Peak EVM, % specifies the measured Peak Error Vector Magnitude (EVM) in percentage. Peak EVM is the maximum EVM across all L1 Post Data symbols

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Post Data Peak MER (dB).vi

Returns the measured Peak Modulation Error Ratio (MER) in dB of L1 Post Signalling Data. The ratio of ideal symbol vector to error vector for a particular symbol and subcarrier gives the instantaneous MER. Peak MER is the maximum MER across all L1 Post Data symbols. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Post Data Peak MER, dB specifies the measured Peak Modulation Error Ratio (MER) in dB. The ratio of ideal symbol vector to error vector for a particular symbol and subcarrier gives the instantaneous MER. Peak MER is the maximum MER across all L1 Post Data symbols.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Post Data Peak EVM Symbol Position.vi

Returns the active subcarrier number corresponding to the Peak Error Vector Magnitude (EVM).
This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Post Data Peak EVM Symbol Position specifies the symbol number corresponding to the Peak Error Vector Magnitude (EVM) of the L1 Post Data Symbols.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Post Data Magnitude Error.vi

Returns the measured Magnitude Error, in dB of L1 Post Signalling Data. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Post Data Magnitude Error, dB specifies the measured L1 Post Data Magnitude Error, in dB.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Post Data Phase Error (deg).vi

Returns the measured Phase Error in degrees of L1 Post Signalling Data. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Post Data Phase Error, deg specifies the L1 Post Data Phase error in degrees.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Pre Data EVM, dB.vi

Returns the measured RMS Error Vector Magnitude (EVM) in dB of L1 Pre Signalling Data. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

For more details refer section Annex C of Digital Video Broadcasting (DVB); Measurement guidelines for DVB systems (ETSI TR 101 290 V1.2.1 (2001-05))

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Pre Data EVM, dB specifies the measured L1 Pret Data Error Vector Magnitude (EVM) in dB.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Pre Data EVM in Percentage.vi

Returns the measured RMS Error Vector Magnitude (EVM) in percentage of L1 Pre Signalling Data. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

For more details refer section Annex C of Digital Video Broadcasting (DVB); Measurement guidelines for DVB systems (ETSI TR 101 290 V1.2.1 (2001-05))

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Pre Data EVM, % specifies the measured L1 Pre Data Error Vector Magnitude (EVM) in percentage.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Pre Data MER, dB.vi

Returns the measured Modulation Error Ratio (MER) in dB of L1 Pre Signalling Data. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

For more details refer section 6.9.2 of Digital Video Broadcasting (DVB); Measurement guidelines for DVB systems (ETSI TR 101 290 V1.2.1 (2001-05))

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Pre Data MER, dB specifies the measured L1 Pre Data Modulation Error Ratio (MER) in dB.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Pre Data Peak EVM, dB.vi

Returns the measured Peak Error Vector Magnitude (EVM) in dB of L1 Pre Signalling Data. The ratio of error vector to the ideal symbol vector for a particular symbol and subcarrier gives the instantaneous EVM. Peak EVM is the maximum EVM across all symbols and subcarriers. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Pre Data Peak EVM, dB specifies the measured Peak Error Vector Magnitude (EVM) in dB. The ratio of error vector to the ideal symbol vector for a particular symbol gives the instantaneous EVM. Peak EVM is the maximum EVM across all L1 Pre Data symbols.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Pre Data Peak EVM in percentage.vi

Returns the measured Peak Error Vector Magnitude (EVM) in percentage of L1 Pre Signalling Data. The ratio of error vector to the ideal symbol vector for a particular symbol and subcarrier gives the instantaneous EVM. Peak EVM is the maximum EVM across all symbols. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Post Data Peak EVM, % specifies the measured Peak Error Vector Magnitude (EVM) in percentage. Peak EVM is the maximum EVM across all L1 Pre Data symbols

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Pre Data Peak MER, dB.vi

Returns the measured Peak Modulation Error Ratio (MER) in dB of L1 Post Signalling Data. The ratio of ideal symbol vector to error vector for a particular symbol and subcarrier gives the instantaneous MER. Peak MER is the maximum MER across all L1 Pre Data symbols. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Pre Data Peak MER, dB specifies the measured Peak Modulation Error Ratio (MER) in dB. The ratio of ideal symbol vector to error vector for a particular symbol and subcarrier gives the instantaneous MER. Peak MER is the maximum MER across all L1 Pre Data symbols.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Pre Data Peak EVM Symbol Position.vi

Returns the active symbol number corresponding to the Peak Error Vector Magnitude (EVM).
This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Pre Data Peak EVM Symbol Position specifies the symbol number corresponding to the Peak Error Vector Magnitude (EVM) of the L1 Pre Data Symbols.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Pre Data Magnitude Error.vi

Returns the measured Magnitude Error, in dB of L1 Pre Signalling Data. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Pre Data Magnitude Error, dB specifies the measured L1 Pre Data Magnitude Error, in dB.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Pre Data Phase Error in degrees.vi

Returns the measured Phase Error in degrees of L1 Pre Signalling Data. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Pre Data Phase Error, deg specifies the L1 Pre Data Phase error in degrees.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get IQ Gain Imbalance.vi

Returns the measured IQ Gain Imbalance value, in dB. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

IQ gain imbalance, dB specifies the desired ratio of I gain to Q gain in dB. Valid values are between –6.0 and +6.0.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Quadrature Skew.vi

Returns the Quadrature skew in degrees. Quadrature Skew specifies the deviation in angle from 90 degrees between the in-phase (I) and quadrature-phase (Q) signals. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Quadrature skew, deg specifies the desired quadrature skew of the complex waveform in degrees. Valid values are between –30.0° and +30.0°.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get IQ Offset.vi

Returns the measured IQ Offset value, in dB. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

IQ Offset, dB specifies the measured IQ Offset value, in dB.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Average Power.vi

Returns the average power of the received signal in dBm. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Average Power, dBm specifies the average power of the received signal in dBm.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Peak Power.vi

Returns the measured peak power of the received signal, in dBm. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Peak Power, dBm specifies the measured peak power of the received signal, in dBm.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 PreSignalling Parameters.vi

Returns the L1 Pre-Signalling Parameters decoded from the P2 Symbol.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Pre Signalling specifies the L1 Pre-Signalling Cluster decoded from the received P2 Symbol.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Post Signalling Params.vi

Returns the L1 Post Signalling parameters based on the decoded P2 symbols.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Post Data Params specifies the L1 Post Signalling Parameters decoded from the acquired P2 symbol.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get PLP Parameters.vi

Returns the PLP Parameters decoded from the P2 Symbol.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

PLP Params specifies the PLP Parameters decoded from the P2 Symbol.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get All Measurements.vi

Returns the DVB-T2 SA Measurement Cluster. This API VI is used for reading all the measurements supported by the toolkit.

DVB-T2 Signal Analysis Handle In

error in (no error) error in can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

Right-click the error in control on the front panel and select Explain Error or Explain Warning from the shortcut menu for more information about the error.

DVB-T2 Signal Analysis Handle Out

All Measurement Cluster

error out error out passes error or warning information out of a VI to be used by other VIs.

Right-click the error out indicator on the front panel and select Explain Error or Explain Warning from the shortcut menu for more information about the error.


MaxEye DVB-T2 SA Get Channel Impulse Response.vi

DVB-T2 Signal Analysis Handle In

error in (no error) error in can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

Right-click the error in control on the front panel and select Explain Error or Explain Warning from the shortcut menu for more information about the error.

DVB-T2 Signal Analysis Handle Out

Channel Impulse Response Trace specifies the Channel Impulse Response in dB. This is an array cluster.. The first cluster contains Path Delay time (micro seconds) array and Channel Impulse Response array in dB. The second cluster contains Path Delay time (micro seconds) array and Path Detection Threshold value.

error out error out passes error or warning information out of a VI to be used by other VIs.

Right-click the error out indicator on the front panel and select Explain Error or Explain Warning from the shortcut menu for more information about the error.


MaxEye DVB-T2 SA Get Channel Frequency Response.vi

Returns the Channel Frequency Response (magnitude response) trace. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements and Channel Estimation Enabled property is set to TRUE.

DVB-T2 Signal Analysis Handle In

error in The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Channel Frequency Response(Magnitude) specifies the Channel Frequency Response (magnitude response) trace in dB.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Channel Frequency Response (Phase).vi

Returns the Channel Frequency Response (phase response) trace. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements and Channel Estimation Enabled property is set to TRUE.

DVB-T2 Signal Analysis Handle In

error in The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Channel Frequency Response(Phase) specifies the channel power in dBm, based on the Center Channel Frequency and Center Channel Bandwidth property configured by the user.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Data PLP Constellation Graph.vi

Returns the Constellation trace of the Data PLP specified in the PLP Index property of the DVB-T2 Signal Analysis Handle. The trace consists of IQ values corresponding to one FEC Block of selected PLP.

This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The returned array needs to be connected to XY graph to view the constellation points.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Data PLP Constellation Graph specifies the constellation graph of PLP specified in the PLP Index property of DVB-T2 Signal Analysis Handle.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Pre Data Constellation Graph.vi

Returns the Constellation trace of L1 Pre Signalling Data. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.
The returned array needs to be connected to XY graph to view the constellation points.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Pre Data Constellation Graph Specifies the Constellation trace of L1 Pre Signalling Data

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get L1 Post Data Constellation Graph.vi

Returns the Constellation trace of L1 Post Signalling Data. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.
The returned array needs to be connected to XY graph to view the constellation points.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

L1 Post Data Constellation Graph Specifies the Constellation trace of L1 Post Signalling Data

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Channel Power.vi

Returns the channel power in dBm, based on the Center Channel Frequency and Center Channel Bandwidth property configured by the user. This measurement is applicable only if the Measurement Mode is set to Spectral Measurements.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Channel Power (dBm) specifies the channel power in dBm, based on the Center Channel Frequency and Center Channel Bandwidth property configured by the user.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Adjacent Channel Powers.vi

Returns the power in dBm, in the adjacent channels based on the ACP Frequency Offsets and ACP Bandwidths property configured by the user. This measurement is applicable only if the Measurement Mode is set to Spectral Measurements.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Adjacent Channel Powers (dBm) specifies the power in dBm, in the adjacent channels.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Spectral Mask Margin.vi

Returns the Spectral Mask Margin in dB. Spectral mask margin is the worst difference between the spectral mask and the measured Power Spectrum. This measurement is applicable only if the Measurement Mode is set to Spectral Measurements.

The toolkit averages the power spectrum over the number of acquisitions specified by the Number of Averages value. The measurement is performed on the average power spectrum.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Spectral Mask Margin,dB specifies the Spectral Mask Margin in dB. Spectral mask margin is the worst difference between the spectral mask and the measured Power Spectrum.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get Spectral Mask Trace.vi

This VI returns the Spectral Mask Trace.

Spectral Mask Trace is a cluster consisting of 3 elements.
1. The first element (f0) returns the initial frequency of the power spectrum.
2. The second element (df) returns the frequency interval between the data points of the power spectrum
3. The third element (y) is a 2D array. The first row returns array of Spectral Emission Mask values as per the SEM Power Offsets and SEM Frequency Offset values configured by the user. The second row returns the Power Spectrum in dBm.

This measurement is applicable only if the Measurement Mode is set to Spectral Measurements.

The toolkit averages the power spectrum over the number of acquisitions specified by the Number of Averages value. The measurement is performed on the average power spectrum.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

Spectral Mask Trace Specifies the data for a real waveform including the start, delta, and actual values.

Spectral Mask Trace is a cluster consisting of 3 elements.
1. The first element (f0) returns the initial frequency of the power spectrum.
2. The second element (df) returns the frequency interval between the data points of the power spectrum
3. The third element (y) is a 2D array. The first row returns array of Spectral Emission Mask values as per the SEM Power Offsets and SEM Frequency Offset values configured by the user. The second row returns the Power Spectrum in dBm.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.


MaxEye DVB-T2 SA Get EVM Vs Symbols.vi

Returns Error Vector Magnitude (EVM) trace. The trace specifies the instantaneous EVM (dB) across one FEC block.

This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

DVB-T2 Signal Analysis Handle In

error in (no error) The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

DVB-T2 Signal Analysis Handle Out

EVM Vs Symbols specifies the Error Vector Magnituce (EVM) trace across one FEC block.

error out The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.