MAXEYE DVB-S Signal Generation Toolkit Help

The MAXEYE DVB-S Signal generation toolkit contains VIs that can be used for generating signals with National Instruments hardware or generate signals in simulation mode as per the DVB-S Standard ETSI EN 300 421 V1.1.2 (1997-08). This document has the information about the toolkit Labview API VIs to help engineers for programming.

____________________________________________________________________________________________________

For more information regarding this help please contact info@maxeyetech.com


MaxEye DVB-S SG Initialize.vi

This VI creates MaxEye DVB-S Generation Handle with the default values and passes the handle to the later VIs.

MaxEye DVB-S SG Initialize.vi

MAXEYE TECHNOLOGIES Private Limited
Digital Video Toolkits - DVB-S Signal Generation

For more details on this help, please write to us at
info@maxeyetech.com


MaxEye DVB-S RFSG Create and Download Waveform.vi

This VI perfoms the following.

i. Checks the configuration parameters in the DVB-S Signal Generation handle and returns an error if the configuration is not valid.
ii. Computes the waveform size, allocates on board memory space for writing waveform.
iii. Creates the DVB-S waveform as per the configured parameters.
iv. Writes the created waveform in the RFSG on board memory.

MaxEye DVB-S RFSG Create and Download Waveform.vi

MAXEYE TECHNOLOGIES Private Limited
Digital Video Toolkits - DVB-S Signal Generation


MaxEye DVB-S SG Create and Save Waveform.vi

This VI perfoms the following.

i. Checks the configuration parameters in the DVB-S Signal Generation handle and returns an error if the configuration is not valid.
ii. Computes the waveform size and returns it to the user
iii. Creates the DVB-S waveform as per the configured parameters.
iv. Writes the created waveform in the file as per the waveform file path location configured by the user

MaxEye DVB-S SG Create and Save Waveform.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Symbol Rate.vi

This VI configures the Symbol Rate property in Hz in the DVB-S signal generation handle.

The default value is 25MHz.

MaxEye DVB-S SG Set Symbol Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Pulse Shaping Filter Type.vi

This VI configures the Pulse shaping filter Type property in the DVB-S signal generation handle. The valid values are
0 (None)
1 (Raised Cosine)
2 (Root Raised Cosine) and
3 (Guassian)

The default value is 2 (Root Raised Cosine).

MaxEye DVB-S SG Set Pulse Shaping Filter Type.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Roll-off Factor.vi

This VI configures the Roll off Factor (Alpha) for the raised cosine and square root raised cosine filters in the DVB-S signal generation handle. This parameter is ignored when the pulse shaping filter parameter is set to none.

The valid values are between 0 to 1.The default value is 0.35.

MaxEye DVB-S SG Set Roll-off Factor.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Samples Per Symbol.vi

This VI configures the Samples per Symbol property for the pulse-shaping filter in the DVB-S signal generation handle.

Sampling rate of the generated waveform = Samples per symbol * Symbol Rate

The default value is 2.

MaxEye DVB-S SG Set Samples Per Symbol.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Number of TS Packets.vi

This VI configures the Number of TS Packets in the DVB-S signal generation handle.

The valid value is greater than 1. The default value is 1.

MaxEye DVB-S SG Set Number of TS Packets.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set RS Encoder Enabled.vi

This VI configures the RS Encoder Enabled? preoperty in the DVB-S signal generation handle. The valid values are TRUE or FALSE.

The default value is TRUE.

MaxEye DVB-S SG Set RS Encoder Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Headroom,dB.vi

This VI configures the Head room property in the DVB-S signal generation handle. The toolkit uses this value for scaling the wave form. If the PAPR of the signal is higher than the Head Room value then the toollkit clips the signal.To avoid clipping the Head Room value should be higher than the PAPR of the signal.

The default value is 12 dB.

MaxEye DVB-S SG Set Headroom,dB.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Code Rate.vi

This VI configures Coding Rate property in the DVB-S signal generation handle. The valid values are
0 (1/2)
1 (2/3)
2 (3/4)
3 (5/6) and
4 (7/8).
The Code Rate selection determines the block length of data bits used for FEC Encoding and the number of Parity Check bits. The default value of the Code Rate is 0.

MaxEye DVB-S SG Set Code Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Filter Length,Symbols.vi

This VI configures the length of the pulse shaping filter in the DVB-S signal generation handle.

The valid values are greater than 1. The default value is 20.

MaxEye DVB-S SG Set Filter Length,Symbols.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Oversampling Enabled.vi

This VI configures the Oversampling Enabled? Property in the DVB-S signal generation handle. The valid value is either TRUE or FALSE.

The default value is FALSE.

MaxEye DVB-S SG Set Oversampling Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Output Sampling Rate.vi

This VI configures the Output Sampling Rate (Hz) property of the DVBS Signal Generation handle.
The toolkit resamples the generated signal to a sampling rate equal to the Output Sampling Rate only if the Over Sampling Enabled property is set to 1(True). If this value is zero then toolkit generates the signal at a default sampling rate which is in turn dependent on the Bandwidth.

MaxEye DVB-S SG Set Output Sampling Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Sample Width.vi

This VI configures the Sample Width property in the DVB-S Signal Generation handle. The toolkit uses this value only when MaxEye DVB-S SG Create and Save Waveform API VI is used for storing the generated waveform in the file.

If the Sample Width property is set to 0(8-bit) the toolkit uses 8 bits for quantizing I and Q sample and if it is set to 1(16-bit) the toolkit uses 16 bits for quantizing the I and Q samples.

MaxEye DVB-S SG Set Sample Width.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Read Waveform From File I8.vi

This VI reads the DVB-S waveform from the given file location based on the value configured in the count input parameter. The number of bytes read from the file is equal to the value of the count. The data is read continuously from the file.

The default value of the count is 1.

MaxEye DVB-S SG Read Waveform From File I8.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Waveform File Path.vi

The VI configures the file location for the Waveform File Path property in DVB-S Signal Generation handle. The toolkit saves the generated waveform in the file when MaxEye DVB-S RFSG Create and Save Waveform API VI is used for the wavefrom creation.

MaxEye DVB-S SG Set Waveform File Path.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Get MPEG2TS PIDs.vi

This VI returns the list of available PIDs from all the MPEG2 TS files used as a payload for generating the signal. This VI returns an empty array if the Payload Mode property is not set to MPEG2TS File(s).

MaxEye DVB-S SG Get MPEG2TS PIDs.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Get Play Duration.vi

This VI returns the Play Duration property in seconds to the DVB-S signal generation handle.

To increase the duration of the generated waveform, set higher value for the Number of TS Packets property.

MaxEye DVB-S SG Get Play Duration.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Get Waveform Size.vi

This VI returns the total Waveform Size of the complex waveform generated for the given configuration in samples to the DVB-S signal generation handle.

MaxEye DVB-S SG Get Waveform Size.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Get Channel Bitrate.vi

This VI returns the Channel Bitrate property in bits/second for the given input configuration to the DVB-S signal generation handle.

The toolkit returns an error if the channel bitrate is lesser than the sum of the bitrate of all the MPEG2TS files.

MaxEye DVB-S SG Get Channel Bitrate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Close Handle.vi

This VI closes the DVB-S Signal Generation handle and resources associated with it.

MaxEye DVB-S SG Close Handle.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Payload Mode.vi

This VI configures the Payload Mode property in the DVB-S Signal Generation handle. The valid values for the Payload property are

PN Sequence - Specifies that the toolkit uses a Galois pseudonoise (PN) bit sequence with configurable order and seed. The seed is the initial state of the PN generator shift register.

User Defined Bits - Specifies that the toolkit repeats the user-supplied bit pattern to achieve the necessary payload length.

Test File - Specifies that the toolkit uses the data stored in the binary file as a payload for creating the waveform.

Test Pattern - Specifies that toolkit uses the value set in the Payload Test Pattern property as a payload for creating the waveform. The length of the Test Pattern is 8 bits. This value is the default.

MPEG2TS File(s) - Specifies that the toolkit uses the MPEG2 TS bitstream as a payload for creating the waveform. Use this payload mode for playing the video in the device under test.

MaxEye DVB-S SG Set Payload Mode.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Number of MPEG2 TS Files.vi

This VI configures the MPEG2 TS Number of Files property in the DVB-S Signal Generation handle. The toolkit combines the multiple TS files to a single TS bitstream based on the bitrate of the each TS file and the channel bitrate of the DVB-S system.

The default value is 1.

MaxEye DVB-S SG Set Number of MPEG2 TS Files.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set MPEG2 TS File Path.vi

The VI configures the file location for the MPEG2TS File Path property in DVB-S Signal Generation handle for the selected TS File index. The toolkit ignores this property if the Payload Mode property value is set to other than MPEG2TS File(s) mode.

MaxEye DVB-S SG Set MPEG2 TS File Path.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Payload File Path.vi

This VI configures the Payload File Path property in the DVB-S Signal Generation handle. The toolkit reads the payload data from the binary file for generating the signal when the Payload Mode property is set to
Test File.

MaxEye DVB-S SG Set Payload File Path.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Payload PN Order.vi

This VI configures the Payload PN Order property in the DVB-S Signal Generation handle . The PN order specifies the order (length of memory) of the pseudorandom bit sequence (PRBS) generator. This property is applicable only when the Payload property is set to PN Sequence.

The default value for the PN Order property is 9.

MaxEye DVB-S SG Set Payload PN Order.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Payload PN Seed.vi

This VI configures the Payload PN seed in the DVB-S Signal Generation handle . This property is applicable only when the Payload property is set to PN Sequence.

The default value for the PN seed is BEEFBEEF.

MaxEye DVB-S SG Set Payload PN Seed.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Payload Test Pattern.vi

This VI configures the Payload test pattern in the DVB-S Signal Generation handle .This property is applicable only when the payload property is set to test pattern.The valid Test Patterns are All 1s,All 0 s,10101010,11110000

The default value for the Test Pattern is All 1s.

MaxEye DVB-S SG Set Payload Test Pattern.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Payload User Defined Bits.vi

This VI configures the Payload User Defined Bits property in the DVB-S Signal Generation handle .This property is applicable only when the Payload Mode property is set to User Defined Bits. The user defined bits should be array of 1s and 0s.

MaxEye DVB-S SG Set Payload User Defined Bits.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Payload Configuration.vi

This VI configures the Payload properties for the DVB-S Signal generation handle. The help for the each of the payload property can be found in the proeprty specific API VIs. This API is used for configuring the multiple API properties using the payload cluster.

MaxEye Technologies Recommends to use property specific API VIs to avoid incompatibility issues with the Future release of this software.

MaxEye DVB-S SG Set Payload Configuration.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Sync Insertion Enabled.vi

This VI configures the Sync Insertion Enabled property in the DVB-S Generation handle. If this property is set to True and the Payload property is set to other than MPEG2TS File(s) then the toolkit inserts the MPEG2 TS bitstream header byte value (0x47) at the beginning of every 188 bytes.

The default value is False.

MaxEye DVB-S SG Set Sync Insertion Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Impairments Enabled.vi

This VI configures the Impairments Enabled property in the DVB-S Signal Generation handle. If this property is set to True then the toolkit adds the impairments to the generated signal as per the user configuration for the supported impairments.

The valid values are True and False. The default value is False.

MaxEye DVB-S SG Set Impairments Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set AWGN Enabled.vi

This VI configures the AWGN Enabled property in the DVB-S Signal Generation handle. If this property is set to True then the toolkit adds Additive White Gaussian Noise (AWGN) to the created waveform based on the value configured in the Carrier to Noise Ratio property.

The valid values are True and False. The default value is False.

MaxEye DVB-S SG Set AWGN Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Carrier to Noise Ratio.vi

This VI configures the value for the Carrier to Noise ratio property, in dB in the DVB-S Signal Generation handle. This value specifies the Carrier to Noise ratio of the generated signal.

The default value is 50dB.

MaxEye DVB-S SG Set Carrier to Noise Ratio.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Frequency Offset.vi

This VI configures the value for the Frequency Offset property, in Hz in the DVB-S Signal Generation Handle. The toolkit applies frequency offset to the created waveform based on the value configured in this property. The applied frequency offset is relative to the signal generator's carrier frequency.

The default value is 0.

MaxEye DVB-S SG Set Frequency Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Clock Offset.vi

This VI configures the value for the Clock Offset property, in PPM in the DVB-S Signal Generation handle. The toolkit applies the clock offset to the generated waveform based on this value. The applied clock offset is relative to the the clock frequency of the signal generator.

The default value is 0.

MaxEye DVB-S SG Set Clock Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set I DC Offset.vi

This VI configures the I DC Offset, in % in the DVB-S Signal Generation Handle. The toolkit adds the DC offset to the in-phase signal component (I) of the complex waveform as a percentage of the root mean square magnitude of the unaltered I signal.

The default value is 0.

MaxEye DVB-S SG Set I DC Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Q DC Offset.vi

This VI configures the value for Q DC Offset property, in % in the DVB-S Signal Generation Handle. The toolkit adds the DC offset to the quadrature-phase signal component (Q) of the complex waveform as a percentage of the root mean square magnitude of the unaltered Q signal.

The default value is 0.

MaxEye DVB-S SG Set Q DC Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set IQ Gain Imbalance.vi

The VI configures the value for the IQ Gain Imbalance property, in dB in the DVB-S Signal Generation handle. This value specifies the ratio, in dB, of the mean amplitude of the in-phase (I) signal to the mean amplitude of the quadrature-phase (Q) signal.

The default value is 0.

MaxEye DVB-S SG Set IQ Gain Imbalance.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Quadrature Skew.vi

This VI configures the value for Quadrature skew Property in degrees in the DVB-S Signal Generation handle. Quadrature Skew specifies the deviation in angle from 90 degrees between the in-phase (I) and quadrature-phase (Q) signals.

The default value for the Quadrature Skew is 0.

MaxEye DVB-S SG Set Quadrature Skew.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Impairment Configuration.vi

This VI configures the Impairment properties for the DVB-S Signal generation handle. The help for the each of the impairment property can be found in the property specific API VIs. This API is used for configuring the multiple API properties using the payload cluster.

MaxEye Technologies Recommends to use property specific API VIs to avoid incompatibility issues with the Future release of this software.

MaxEye DVB-S SG Set Impairment Configuration.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SG Set Progress Bar Control Refnum.vi

This VI configures the control refnum in the DVB-S Generation Handle for progress status bar update in the user front panel. Use this API VI to monitor the progress of the waveform generation. You need to create progress bar control in the labview frontpanel and then pass the control refnum as an input to this VI.

MaxEye DVB-S SG Set Progress Bar Control Refnum.vi

MAXEYE TECHNOLOGIES Private Limited