MAXEYE DVB-S Signal Analysis Toolkit Help

The MAXEYE DVB-S Signal analysis toolkit contains LabVIEW VIs to perform measurements on DVB-S signals that confirm with ETSI standard EN 300 421 V 1.1.2 (1997-08). Refer to the ETSI EN 300 421 standard for the signal specifications and this document assumes that the user is familiar with the DVB-S standard specification. This document has information about the toolkit Labview API VIs to help engineers for programming.

____________________________________________________________________________________________________

For more information regarding this help please contact info@maxeyetech.com


MaxEye DVB-S SA Initialize.vi

This VI creates MaxEye DVB-S Signal Analysis Handle with the default values and passes the handle to the later VIs.

MaxEye DVB-S SA Initialize.vi

MAXEYE TECHNOLOGIES Private Limited
Digital Video Toolkits - DVB-S Signal Analysis

For more details on this help, please write to us at
info@maxeyetech.com


MaxEye DVB-S SA RFSA Configure Hardware.vi

Configures the following properties in the NI RFSA hardware,

1. For Demodulation Measurements

i. Configures the NI RFSA Acquisition Type to IQ or Spectrum Mode based on the measurement mode value configured by the user.
ii. Configures the NI RFSA Number of Records property to Number of Averages value configured by the user.
iii. Configures Number of Records Is Finite to TRUE.
iv. Configures the NI RFSA IQ Rate property to the reciprocal of the elementary period. The tool kit internally computes the elementary period based on the Bandwidth value configured by the user.
v. Configures the NI RFSA trigger settings based on the PreTrigger Delay and Minimum Quite Time values.
vi. Configures the NI RFSA Number of Samples property based on the Acquisition Length and IQ Rate.

2. Spectral Measurements

i. Configures the NI RFSA Acquisition Type to IQ or Spectrum Mode based on the measurement mode value configured by the user.
ii. Configures the NI RFSA Power Spectrum Units property to Volts Squared.
iii. Configures the NI RFSA Number of Averages property to Number of Averages value.
iv. Configures the NI RFSA Averaging Mode property to Averaging Mode value.

MaxEye DVB-S SA RFSA Configure Hardware.vi

MAXEYE TECHNOLOGIES Private Limited
Digital Video Toolkits - DVB-S Signal Analysis


MaxEye DVB-S SA RFSA Measure.vi

This VI perfoms the following.

i. Checks the configuration parameters in the DVB-S Signal Analysis handle and returns an error if the configuration is not valid.
ii. Configures the NI RFSA properties based on the user configuration. For more details refer MaxEye DVB-S RFSA Configure Hardware.vi documentation.
iii. Initiates the Acquisition by calling niRFSA Initiate.vi.
iv. Based on the measurement mode configured by the user, either niRFSA Fetch IQ.vi or niRFSA Read Power Spectrum.vi is used for acquiring the signal.
v. Performs Demodulation Measurements or Spectral Measurements based on the Measurement Mode.

MaxEye DVB-S SA RFSA Measure.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA USRP Measure.vi

This VI perfoms the following.

i. Checks the configuration parameters in the DVB-S Signal Analysis handle and returns an error if the configuration is not valid.
ii. Initiates the Acquisition by calling niUSRP Initiate.vi.
iv. The signal is acquired using niUSRP Fetch Rx Data.vi.
v. Performs Demodulation Measurements or Spectral Measurements based on the Measurement Mode.

MaxEye DVB-S SA USRP Measure.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Close Handle.vi

Closes the DVB-S Signal Analysis handle and resources associated with it.

MaxEye DVB-S SA Close Handle.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set Roll-off Factor.vi

Configures the Roll-off Factor (Alpha) for the raised cosine and square root raised cosine filters in the DVB-S signal analysis handle.

MaxEye DVB-S SA Set Roll-off Factor.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set Symbol Rate.vi

Configures the Symbol Rate property in Hz in the DVB-S signal analysis handle.

MaxEye DVB-S SA Set Symbol Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set Samples per Symbol.vi

Configures the Samples Per Symbol property for the pulse-shaping filter in the DVB-S signal analysis handle.

The default value is 2.

MaxEye DVB-S SA Set Samples per Symbol.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set Filter Length.vi

Configures the length of the matched filter in the DVB-S Signal Analysis Handle.

The valid values are greater than 1. The default value is 20.

MaxEye DVB-S SA Set Filter Length.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set Measurement Mode.vi

Configures the Measurement Mode property of the DVB-S Signal Analysis handle.

The valid enum values of Measurement Mode are
0 (Demodulation Measurements)
1 (Spectral Measurements)

MaxEye DVB-S SA Set Measurement Mode.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set Number of Averages.vi

Configures the Number of Averages property of the DVB-S Signal Analysis handle. The measurement results are averaged over the number specified by Number of Averages.

MaxEye DVB-S SA Set Number of Averages.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set Acquisition Length.vi

Configures the Acquisition Length property of the DVB-S Signal Analysis handle. The toolkit reads the number of samples equivalent to the Acquisition Length.

MaxEye DVB-S SA Set Acquisition Length.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set Minimum Quite Time.vi

Configures the Minimum Quite Time property of the DVB-S Signal Analysis handle. This value specifies the minimum time below the trigger value during which the signal must remain off, in order to trigger.

MaxEye DVB-S SA Set Minimum Quite Time.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set Measurement No of Symbols.vi

Configures the Measurement Number of Symbols to be used for DVB-S Signal Analysis Handle.

MaxEye DVB-S SA Set Measurement No of Symbols.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set PreTrigger Delay.vi

Configure the PreTrigger Delay property of the DVB-S Signal Analysis handle.

MaxEye DVB-S SA Set PreTrigger Delay.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set Code Rate.vi

Configures the Code rate property of the DVB-S Signal Analysis Handle.

The valid values for Code rate are:
0 (1/2)
1 (2/3)
2 (3/4)
3 (5/6)
4 (7/8)

MaxEye DVB-S SA Set Code Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set FFT Window type.vi

Configures the FFT Window Type property of the DVB-S Signal Analysis handle. FFT Window Type is the time-domain window to apply to the time signal.

The valid enum values of FFT Window Types are,
0 (Rectangle)
1 (Hanning (default))
2 (Hamming)
3 (Blackman-Harris)
4 (Exact Blackman)
5 (Blackman)
6 (Flat Top)
7 (4 Term B-Harris)
8 (7 Term B-Harris)
9 (Low Sidelobe)
11 (Blackman Nutall)
30 (Triangle)
31 (Bartlett-Hanning)
32 (Bohman)
33 (Parzen)
34 (Welch)
60 (Kaiser)
61 (Dolph-Chebyshev)
62 (Gaussian)

MaxEye DVB-S SA Set FFT Window type.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set Center Channel Frequency.vi

Configures the Center Channel Frequency property of the DVB-S Signal Analysis handle, in Hz.

MaxEye DVB-S SA Set Center Channel Frequency.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set Center Channel Bandwidth.vi

Configures the Center Channel Bandwidth property of the DVB-S Signal Analysis handle.

Specifies the frequency range for each channel, in Hz.

MaxEye DVB-S SA Set Center Channel Bandwidth.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set ACP Frequency Offset.vi

Configures the Adjacent Channel Frequency Offsets property of the DVB-S Signal Analysis handle, in Hz.

Adjacent Channel Frequency Offsets specifies the distance from the center frequency of the main channel to the center frequency of the adjacent channels.

MaxEye DVB-S SA Set ACP Frequency Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set ACP Bandwidth.vi

Configures the Adjacent Channel Bandwidths property of the DVB-S Signal Analysis handle.

Adjacent Channel Bandwidth specifies the frequency range of each channel, in Hz

MaxEye DVB-S SA Set ACP Bandwidth.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set SEM Frequency Offset.vi

Configures the Spectral Emission Mask (SEM) Frequency Offsets property of the DVB-S Signal Analysis Handle. The SEM Frequency Offsets specifies the offset in Hz from the center frequency.

The toolkit uses this property to compute the Spectral Emission Mask.

When the Auto SEM Mask Enabled is set to true the Spectral Emission Mask (SEM) Frequency Offsets is calculated for Roll-off factor 0.35.

The details with respect to Roll off factor 0.35, can be found in Table A.1: Definition of points given in figure A.1, in DVB-S standard ETSI EN 300 421 V1.1.2 (1997-98).

MaxEye DVB-S SA Set SEM Frequency Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set SEM Power Offset.vi

Configures the Spectral Emission Mask (SEM) Power Offset property of the DVB-S Signal Analysis handle in dB. The Power Offset levels corresponds to the each frequency offset points specified by SEM Frequency Offsets Property. The Power Offset is relative to the power level specified by the SEM Reference Power Level Type property.

The toolkit uses this property to compute the Spectral Emission Mask.

When the Auto SEM Mask Enabled is set to true the Spectral Emission Mask (SEM) Power Offsets is calculated for Roll-off factor 0.35.

The details with respect to Roll off factor 0.35, can be found in Table A.1: Definition of points given in figure A.1, in DVB-S standard ETSI EN 300 421 V1.1.2 (1997-98).

MaxEye DVB-S SA Set SEM Power Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set SEM Reference Level Type.vi

Configures the Spectral Emission Mask (SEM) Reference Level Type property of the DVB-S Signal Analysis handle.

The toolkit uses this property to compute the Spectral Emission Mask.

The valid enum values are
0 (Peak Power)
1 (Total Channel Power)
2 (User Defined Power Level)

MaxEye DVB-S SA Set SEM Reference Level Type.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set SEM Reference Power Level.vi

Configures the Spectral Emission Mask (SEM) Reference Power Level property in dBm, of the DVB-S signal Analysis handle. The toolkit uses this property when the SEM Reference Level Type property is set to User Defined Power Level.

The SEM Reference Power Level and SEM Power Offsets are used to compute the absolute power levels for each SEM frequency offset points.

The toolkit uses this property to compute the Spectral Emission Mask.

MaxEye DVB-S SA Set SEM Reference Power Level.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set Weighting Mode.vi

Configures the Weighting mode property of the DVB-S Signal analysis handle. This property is applicable only if the Measurement Mode is Spectral Measurements.

The valid enum values are
0 (Linear)
1 (Exponential)

MaxEye DVB-S SA Set Weighting Mode.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Set Averaging Mode.vi

Configures the Averaging Mode property of the DVB-S Signal Analysis handle. The Averaging mode specifies the type of averaging method used for spectral acquisition. This property is applicable only if the Measurement Mode is Spectral Measurements.

The valid enum values for Averaging mode are
0 (No Averaging)
1 (Vector Averaging)
2 (RMS Averaging)
3 (Peak Hold)

MaxEye DVB-S SA Set Averaging Mode.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get RMS EVM dB.vi

Returns the measured RMS Error Vector Magnitude (EVM) in dB. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DVB-S SA Get RMS EVM dB.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get RMS EVM in percentage.vi

Returns the measured RMS Error Vector Magnitude (EVM) in percentage. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DVB-S SA Get RMS EVM in percentage.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get Peak EVM dB.vi

Returns the measured Peak Error Vector Magnitude (EVM) in dB. The ratio of error vector to the ideal symbol vector for a particular symbol gives the instantaneous EVM. Peak EVM is the maximum EVM across all symbols. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

MaxEye DVB-S SA Get Peak EVM dB.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get Peak EVM in percentage.vi

Returns the measured Peak Error Vector Magnitude (EVM) in percentage. The ratio of error vector to the ideal symbol vector for a particular symbol gives the instantaneous EVM. Peak EVM is the maximum EVM across all symbols . This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

MaxEye DVB-S SA Get Peak EVM in percentage.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get Peak EVM Symbol Position.vi

Returns the symbol number corresponding to the Peak Error Vector Magnitude (EVM).
This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

MaxEye DVB-S SA Get Peak EVM Symbol Position.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get MER in dB.vi

Returns the measured Modulation Error Ratio (MER) in dB. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DVB-S SA Get MER in dB.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get Peak MER (dB).vi

Returns the measured Peak Modulation Error Ratio (MER) in dB. The ratio of ideal symbol vector to error vector for a particular symbol gives the instantaneous MER. Peak MER is the maximum MER across all symbols. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

MaxEye DVB-S SA Get Peak MER (dB).vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get Frequency Offset.vi

Returns the average Frequency Offset in Hz. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DVB-S SA Get Frequency Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get Clock Offset.vi

Returns the Clock Offset measured in PPM. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

MaxEye DVB-S SA Get Clock Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get RMS Magnitude Error.vi

Returns the measured RMS Magnitude Error, in percentage. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DVB-S SA Get RMS Magnitude Error.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get Phase Error.vi

Returns the measured Phase Error in degrees. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DVB-S SA Get Phase Error.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get IQ Gain Imbalance.vi

Returns the measured IQ Gain Imbalance value, in dB. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DVB-S SA Get IQ Gain Imbalance.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get Quadrature Skew.vi

Returns the Quadrature skew in degrees. Quadrature Skew specifies the deviation in angle from 90 degrees between the in-phase (I) and quadrature-phase (Q) signals. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DVB-S SA Get Quadrature Skew.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get IQ Offset.vi

Returns the measured IQ Offset value, in dB. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DVB-S SA Get IQ Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get Average Power.vi

Returns the average power of the received signal in dBm. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

MaxEye DVB-S SA Get Average Power.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get Peak Power.vi

Returns the measured peak power of the received signal, in dBm. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

MaxEye DVB-S SA Get Peak Power.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get Constellation Graph.vi

Returns the Constellation trace. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.
The returned array needs to be connected to XY graph to view the constellation points.

MaxEye DVB-S SA Get Constellation Graph.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get EVM vs Symbols.vi

Returns the Error Vector Magnitude (EVM) values. The returned array needs to be connected to a waveform graph to visualize the EVM Vs Symbols.

This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

MaxEye DVB-S SA Get EVM vs Symbols.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get MER vs Symbols.vi

Returns the Modulation Error Ratio (MER) values. The returned array needs to be connected to a waveform graph to visualize MER Vs Symbols.

This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

MaxEye DVB-S SA Get MER vs Symbols.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get RMS Magnitude Error vs Symbols.vi

Returns the RMS Magnitude Error values. The returned array needs to be connected to a waveform graph to visualize the RMS Magnitude Error Vs Symbols.

This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

MaxEye DVB-S SA Get RMS Magnitude Error vs Symbols.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get RMS Phase Error vs symbols.vi

Returns the RMS Phase Error values. The returned array needs to be connected to a waveform graph to visualize the RMS Phase Error Vs Symbols.

This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

MaxEye DVB-S SA Get RMS Phase Error vs symbols.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get Channel Power.vi

Returns the channel power in dBm, based on the Center Channel Frequency and Center Channel Bandwidth property configured by the user. This measurement is applicable only if the Measurement Mode is set to Spectral Measurements.

MaxEye DVB-S SA Get Channel Power.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get Adjacent Channel Powers.vi

Returns the power in dBm, in the adjacent channels based on the ACP Frequency Offsets and ACP Bandwidths property configured by the user. This measurement is applicable only if the Measurement Mode is set to Spectral Measurements.

MaxEye DVB-S SA Get Adjacent Channel Powers.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get Spectral Mask Trace.vi

Returns the Spectral Mask Trace.

Spectral Mask Trace is a cluster consisting of 3 elements.
1. The first element (f0) returns the initial frequency of the power spectrum.
2. The second element (df) returns the frequency interval between the data points of the power spectrum
3. The third element (y) is a 2D array. The first row returns array of Spectral Emission Mask values as per the SEM Power Offsets and SEM Frequency Offset values configured by the user. The second row returns the Power Spectrum in dBm.

This measurement is applicable only if the Measurement Mode is set to Spectral Measurements.

The toolkit averages the power spectrum over the number of acquisitions specified by the Number of Averages value. The measurement is performed on the average power spectrum.

MaxEye DVB-S SA Get Spectral Mask Trace.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S SA Get Spectral Mask Margin.vi

Returns the Spectral Mask Margin in dB. Spectral mask margin is the worst difference between the spectral mask and the measured Power Spectrum. This measurement is applicable only if the Measurement Mode is set to Spectral Measurements.

The toolkit averages the power spectrum over the number of acquisitions specified by the Number of Averages value. The measurement is performed on the average power spectrum.

MaxEye DVB-S SA Get Spectral Mask Margin.vi

MAXEYE TECHNOLOGIES Private Limited