MAXEYE DVB-S2 Signal Generation Toolkit Help

The MAXEYE DVB-S2 Signal generation toolkit contains VIs that can be used for generating signals with National Instruments hardware or generate signals in simulation mode as per the ETSI standard EN 302307 version 1.3.1 (2013-03). This document has information about the toolkit Labview API VIs to help engineers for programming.

____________________________________________________________________________________________________

For more information regarding this help please contact info@maxeyetech.com


MaxEye DVB-S2 SG Initialize.vi

This VI creates MaxEye DVB-S2 Generation Handle with the default values and passes the handle to the later VIs.

MaxEye DVB-S2 SG Initialize.vi

MAXEYE TECHNOLOGIES Private Limited
Digital Video Toolkits - DVB-S2 Signal Generation

For more details on this help, please write to us at
info@maxeyetech.com


MaxEye DVB-S2 SG RFSG Create and Download Waveform.vi

This VI performs the following:

(i) Checks the configuration parameters in DVB-S2 signal generation handle and returns an error if the configuration is not valid.
(ii) Computes the waveform size, aloocates on board memory space for writing waveform.
(iii) Creates the DVB-S2 waveform as per the configured parameters.
(iv) Writes the created waveform in the RFSG on board memory.

MaxEye DVB-S2 SG RFSG Create and Download Waveform.vi

MAXEYE TECHNOLOGIES Private Limited
Digital Video Toolkits - DVB-S2 Signal Generation


MaxEye DVB-S2 SG Create and Save Waveform.vi

This VI performs the following:

(i) Checks the configuration parameters in DVB-S2 signal generation handle and returns an error if the configuration is not valid.
(ii) Computes the waveform size and returns it to the user.
(iii) Creates the DVB-S2 waveform as per the configured parameters.
(iv) Writes the created waveform in the file as per the waveform file path location configured by the user.

MaxEye DVB-S2 SG Create and Save Waveform.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Read Waveform From File.vi

This VI reads the DVB-S2 waveform from the given file location based on the value configured in the count input parameter. The number of bytes read from the file is equal to the value of the count. The data is read continuously from the file.

The default value of the count is 1.

MaxEye DVB-S2 SG Read Waveform From File.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Input Stream Format.vi

This VI configures the Input Stream Format in the DVB-S2 signal generation handle.

The valid values are:
0 (Generic Packetized Stream)
1 (Generic Continuous Stream)
2 (Reserved)
3 (Transport Stream)

The default value is 3(Transport Stream). The current version of the toolkit only supports 3 (Transport Stream).

MaxEye DVB-S2 SG Set Input Stream Format.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Input Stream Type.vi

This VI configures the Input Stream Type property in the DVB-S2 signal generation handle. The valid values are
0 (Multiple Stream)
1 (Single Stream)

The default value is 1 (Single Stream).

MaxEye DVB-S2 SG Set Input Stream Type.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Coding and Modulation Type.vi

This VI configures the Coding and Modulation Type property in the DVB-S2 signal generation handle. The valid values are
0 (Adaptive Coding and Modulation)
1 (Constant Coding and Modulation)

The default value is 1 (Constant Coding and Modulation).

MaxEye DVB-S2 SG Set Coding and Modulation Type.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Input Stream Sync Type.vi

This VI configures the Input Stream Synchronization Type property in the DVB-S2 signal generation handle. This parameter is not relavant for single transport stream broadcasting application. For more details refer to section 5.1.2 in DVB-S2 standard ETSI EN 302 307 V1.3.1 (2013-03).

The valid values are:
0 (Inactive)
1 (Active)

The default value is 0(Inactive).

MaxEye DVB-S2 SG Set Input Stream Sync Type.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Null Packet Deletion Type.vi

This VI configures the Null Packet Deletion Type property in the DVB-S2 signal generation handle. This property is valid only if the Coding and Modulation Type property is set to Adaptive Coding and Modulation and the Input Stream Format property is set to Transport Stream. For more details refer to section 5.1.3 in DVB-S2 standard ETSI EN 302 307 V1.3.1 (2013-03).

The valid values are:
0 (Inactive)
1 (Active)

The default value is 0(Inactive).

MaxEye DVB-S2 SG Set Null Packet Deletion Type.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Roll Off Factor.vi

This VI configures the Roll-off Factor (Alpha) for the raised cosine and square root raised cosine filters in the DVB-S2 signal generation handle. The toolkit ignores this property if the Pulse Shaping Filter Type property is set to none.

The valid values are
0(0.35)
1(0.25)
2(0.20)

The default value is 0(0.35).

MaxEye DVB-S2 SG Set Roll Off Factor.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set ISCR Type.vi

This VI configures the ISCR Type property in the DVB-S2 signal generation handle. This parameter is relavant only if Input stream synchronization type is active. For more details refer to annex D (normative): D.2 in DVB-S2 standard ETSI EN 302 307 V1.3.1 (2013-03).

The valid values are:
0 (Short)
1 (Long)

The default value is 0(Short).

MaxEye DVB-S2 SG Set ISCR Type.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Symbol Rate.vi

This VI configures the Symbol Rate property in Hz in the DVB-S2 signal generation handle.

The default value is 30 MHz.

MaxEye DVB-S2 SG Set Symbol Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Pulse Shaping Filter Type.vi

This VI configures the Pulse Shaping Filter Type property in the DVB-S2 signal generation handle. The valid values are
0 (None)
1 (Raised Cosine)
2 (Root Raised Cosine) and
3 (Guassian)

The default value is 2 (Root Raised Cosine).

MaxEye DVB-S2 SG Set Pulse Shaping Filter Type.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Insert Pilot.vi

This VI configures the Pilot Insertion Enabled? property in the DVB-S2 signal generation handle. This parameter enables pilot block insertion to help receiver synchronization. For more detials refer to section 5.5 in DVB-S2 standard ETSI EN 302 307 V1.3.1 (2013-03).

The valid values are 0 (False) and 1 (True).
The default value is 1 (True).

MaxEye DVB-S2 SG Set Insert Pilot.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Number of Streams.vi

This VI configures the Number of Streams property in the DVB-S2 signal generation handle.
The valid value should be greater than 0. The default value is 1 and this corresponds to single stream.

MaxEye DVB-S2 SG Set Number of Streams.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Samples Per Symbol.vi

This VI configures the Samples Per Symbol property for the pulse-shaping filter in the DVB-S2 signal generation handle.

Sampling rate of the generated waveform = Samples per symbol * Symbol Rate

The default value is 2.

MaxEye DVB-S2 SG Set Samples Per Symbol.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Filter Length Symbols.vi

This VI configures the length of the pulse shaping filter in the DVB-S2 signal generation handle.

The valid values are greater than 1. The default value is 20.

MaxEye DVB-S2 SG Set Filter Length Symbols.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Number of Frames.vi

This VI configures the Number of Frames property in the DVB-S2 signal generation handle. The toolkit uses the same frame configuration for all the frames and the payload is continuous across frames.

The valid value should be greater than 0.

The default value is 1.ss

MaxEye DVB-S2 SG Set Number of Frames.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Headroom.vi

This VI configures the Head room property in the DVB-S2 Signal Generation handle. The toolkit uses this value for scaling the waveform. If the PAPR of the signal is higher than the Head room value then the toolkit clips the signal. To avoid clipping Head room value should be higher than PAPR of the signal.

The default value is 12 dB.

MaxEye DVB-S2 SG Set Headroom.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Progress Bar Control Refnum.vi

This VI configures the control refnum in the DVB-S2 Generation Handle for progress status bar update in the user front panel. Use this API VI to monitor the progress of the waveform generation. You need to create progress bar control in the labview frontpanel and then pass the control refnum as an input to this VI.

MaxEye DVB-S2 SG Progress Bar Control Refnum.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Waveform File Path.vi

This VI configures the file location for the Waveform File Path property in DVB-S2 Signal Generation handle. The toolkit saves the generated waveform in the file when MaxEye DVB-S2 RFSG Create and Save Waveform API VI is used for the wavefrom creation.

MaxEye DVB-S2 SG Set Waveform File Path.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Oversampling Enabled.vi

This VI configures the Oversampling Enabled property in the DVB-S2 Signal Generation handle. If this property is set to True then the toolkit resamples the generated signal based on the value configured by the user for the Output Sampling Rate property.

The valid values are True and False. The default value is False.

MaxEye DVB-S2 SG Set Oversampling Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Output Sampling Rate.vi

This VI configures the Output Sampling Rate (Hz) property of the DVB-S2 Signal Generation handle.
The toolkit resamples the generated signal to a sampling rate equal to the Output Sampling Rate only if the Over Sampling Enabled property is set to 1(True).

MaxEye DVB-S2 SG Set Output Sampling Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Sample Width.vi

This VI configures the Sample Width property in the DVB-S2 Signal Generation handle. The toolkit uses this value only when MaxEye DVB-S2 SG Create and Save Waveform API VI is used for storing the generated waveform in the file.

If the Sample Width property is set to 0(8-bit) the toolkit uses 8 bits for quantizing I and Q sample and if it is set to 1(16-bit) the toolkit uses 16 bits for quantizing the I and Q samples.

Default value is 0(8-bit)

MaxEye DVB-S2 SG Set Sample Width.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Get Channel Bit Rate.vi

This VI returns the Channel Bit Rate property in bits/second for the selected Stream Index and for the given input configuration

MaxEye DVB-S2 SG Get Channel Bit Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Get Play Duration.vi

This VI returns the value of Play Duration property in seconds for the given configuration..

To increase the play duration of the generated waveform, set higher value for the Number of Frames property.

MaxEye DVB-S2 SG Get Play Duration.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Get PAPR.vi

This VI returns the PAPR property for the given input configuration.

MaxEye DVB-S2 SG Get PAPR.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Get MPEG2TS PIDs.vi

This VI returns the list of available PIDs from all the MPEG2 TS files used as a payload for generating the signal for the selected Stream Index.

The default value for Stream Index is 0.

This VI returns an empty array if the Payload Mode property is not set to MPEG2TS File(s).

MaxEye DVB-S2 SG Get MPEG2TS PIDs.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Close Handle.vi

This VI closes the DVB-S2 Signal Generation handle and resources associated with it.

MaxEye DVB-S2 SG Close Handle.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Stream Configuration.vi

This VI configures the Service Configuration properties for the DVB-S2 Signal generation handle. The help for the each of the service configuration property can be found in the proeprty specific API VIs. This API is used for configuring the multiple API properties using the payload and service configuration cluster.

MaxEye Technologies Recommends to use property specific API VIs to avoid incompatibility issues with the Future release of this software.

MaxEye DVB-S2 SG Set Stream Configuration.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Digital Video Payload Configuration .vi

This VI configures the Digital Video Payload properties in DVB-S2 Signal generation handle for the selected Stream index. The help for each of the Digital Video Payload property can be found in the proeprty specific API VIs. This API is used for configuring the multiple API properties using the Digital Video Payload cluster.

The default value for Stream Index is 0.

MaxEye Technologies Recommends to use property specific API VIs to avoid incompatibility issues with the Future release of this software.

MaxEye DVB-S2 SG Set Digital Video Payload Configuration .vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Modulation Type.vi

This VI configures the Modulation Type property in the DVB-S2 Signal generation handle for the selected Stream Index.

The valid values are:
0 (QPSK)
1 (8 PSK)
2 (16 APSK)
3 (32 APSK)

The default value for Stream Index is 0. The default value is 0(QPSK).

MaxEye DVB-S2 SG Set Modulation Type.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Input Stream Identifier.vi

This VI configures the Input Stream Identifier property in the DVB-S2 Signal generation handle for the selected Stream Index. This property is applicable only for Multiple Stream Input.

The default value for Stream Index is 0. The default value for Input Stream Identifier is 0.

MaxEye DVB-S2 SG Set Input Stream Identifier.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set FEC Frame Type.vi

This VI configures the FEC Frame Type property in the DVB-S2 Signal generation handle for the selected Stream Index.

The valid values are:
0 (Normal)
1 (Short)

The default value for Stream Index is 0. The default value is 0(Normal).

MaxEye DVB-S2 SG Set FEC Frame Type.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Code Rate.vi

This VI configures the LDPC Code Rate in the DVB-S2 Signal generation handle for the selected Stream Index. The details of the Coding parameters can be found in the Table 5(a),(b) in DVB-S2 standard ETSI EN 302 307 V1.3.1 (2013-03).

The valid values are:
0 (1/4)
1 (1/3)
2 (2/5)
3 (1/2)
4 (3/5)
5 (2/3)
6 (3/4)
7 (4/5)
8 (5/6)
9 (8/9)
10 (9/10)

The default value for Stream Index is 0. The defualt value for Code rate is 3/4.

MaxEye DVB-S2 SG Set Code Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Paylode Mode.vi

This VI configures the Payload Mode property in the DVB-S2 Signal Generation handle for the selected Stream Index.

The valid values for the Payload Mode property are

PN Sequence - Specifies that the toolkit uses a Galois pseudonoise (PN) bit sequence with configurable order and seed. The seed is the initial state of the PN generator shift register.

User Defined Bits - Specifies that the toolkit repeats the user-supplied bit pattern to achieve the necessary payload length.

Test Pattern - Specifies that toolkit uses the value set in the Payload Test Pattern property as a payload for creating the waveform. The length of the Test Pattern is 8 bits. This value is the default.

Test File - Specifies that the toolkit uses the data stored in the binary file as a payload for creating the waveform.

MPEG2TS File(s) - Specifies that the toolkit uses the MPEG2 TS bitstream as a payload for creating the waveform. Use this payload mode for playing the video in the device under test.

MPEG2TS Audio - Specifies that the toolkit uses the MPEG2 TS Audio bitstream as a payload for creating the waveform. Use this payload mode for playing the audio in the device under test.

The default value for Stream Index is 0. The default value for Payload Mode is PN Sequence.

MaxEye DVB-S2 SG Set Paylode Mode.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Payload User Defined Bits.vi

This VI configures the Payload User Defined Bits property in the DVB-S2 Signal Generation handle for the selected Stream Index. This property is applicable only when the Payload Mode property is set to User Defined Bits.

The user defined bits should be array of 1s and 0s. The default value for Stream Index is 0.

MaxEye DVB-S2 SG Set Payload User Defined Bits.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Payload Test Pattern.vi

This VI configures the Payload Test Pattern property in the DVB-S2 Signal Generation handle for the selected Stream Index. This property is applicable only when the Payload mode property is set to test pattern.

The valid Test Patterns are All 1s,All 0 s,10101010,11110000. The default value for Stream index is 0. The default value for the Test Pattern is All 1s.

MaxEye DVB-S2 SG Set Payload Test Pattern.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Payload PN Seed.vi

This VI configures the Payload PN seed property in the DVB-S2 Signal Generation handle for the selected Stream Index. This property is applicable only when the Payload Mode property is set to PN Sequence.

The default value for Stream index is 0. The default value for the PN seed is BEEFBEEF.

MaxEye DVB-S2 SG Set Payload PN Seed.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Payload PN Order.vi

This VI configures the Payload PN Order property in the DVB-S2 Signal Generation handle for the selected Stream Index

The PN order specifies the order (length of memory) of the pseudorandom bit sequence (PRBS) generator. This property is applicable only when the Payload Mode property is set to PN Sequence.

The default value for Stream index is 0. The default value for the PN Order property is 9.

MaxEye DVB-S2 SG Set Payload PN Order.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Payload File Path.vi

This VI configures the Payload File Path property in DVB-S2 Signal Generation handle for the selected Stream Index.
The toolkit reads the payload data from the binary file for generating the signal when the Payload Mode property is set to Test File.
The default value for Stream index is 0.

MaxEye DVB-S2 SG Set Payload File Path.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Sync Insertion Enabled.vi

This VI configures the Sync Insertion Enabled property in the DVB-S2 Signal generation handle for the selected Stream Index.

The Sync Insertion Enabled can either take enum values 0(False) or 1(True). The default value is set to 0(False). The default value for Stream Index is 0 and Sync Insertion Enabled is 0(False).

MaxEye DVB-S2 SG Set Sync Insertion Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set MPEG2 TS Number of TS Files.vi

This VI configures the MPEG2 TS Number of Files property in the DVB-S2 Signal Generation handle for the selected Stream Index.

The default value for Stream Index is 0. The default value for MPEG2 TS Number of Files is 1.

The toolkit combines the multiple TS files to a single TS bitstream based on the bitrate of the each TS file and the channle bitrate of the DVB-S2 system. The channel bitrate of the DVB-S2 system is determined by the signal configuration.

The default value is 1.

MaxEye DVB-S2 SG Set MPEG2 TS Number of TS Files.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set MPEG2TS File Path.vi

The VI configures the file location for the MPEG2TS File Path property in DVB-S2 Signal Generation handle for the selected TS File index and Stream Index.

The default value for Stream Index is 0.

The toolkit ignores this property if the Payload Mode property value is set to other than MPEG2TS File(s) mode.

MaxEye DVB-S2 SG Set MPEG2TS File Path.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Impairments Enabled.vi

This VI configures the Impairments Enabled property in the DVB-S2 Signal Generation handle. If this property is set to True then the toolkit adds the impairments to the generated signal as per the user configuration for the supported impairments.

The valid values are True and False. The default value is False.

MaxEye DVB-S2 SG Set Impairments Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set AWGN Enabled.vi

This VI configures the AWGN Enabled property in the DVB-S2 Signal Generation handle. If this property is set to True then the toolkit adds Additive White Gaussian Noise (AWGN) to the created waveform based on the value configured in the Carrier to Noise Ratio property.

The valid values are True and False. The default value is False.

MaxEye DVB-S2 SG Set AWGN Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Carrier to Noise.vi

This VI configures the value for the Carrier to Noise ratio property, in dB in the DVB-S2 Signal Generation handle. This value specifies the Carrier to Noise ratio of the generated signal.

The default value is 50dB.

MaxEye DVB-S2 SG Set Carrier to Noise.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set I DC Offset.vi

This VI configures the I DC Offset, in % in the DVB-S2 Signal Generation Handle. The toolkit adds the DC offset to the in-phase signal component (I) of the complex waveform as a percentage of the root mean square magnitude of the unaltered I signal.

The default value is 0.

MaxEye DVB-S2 SG Set I DC Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Q DC Offset.vi

This VI configures the value for Q DC Offset property, in % in the DVB-S2 Signal Generation Handle. The toolkit adds the DC offset to the quadrature-phase signal component (Q) of the complex waveform as a percentage of the root mean square magnitude of the unaltered Q signal.

The default value is 0.

MaxEye DVB-S2 SG Set Q DC Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set IQ Gain Imbalance.vi

The VI configures the value for the IQ Gain Imbalance property, in dB in the DVB-S2 Signal Generation handle. This value specifies the ratio, in dB, of the mean amplitude of the in-phase (I) signal to the mean amplitude of the quadrature-phase (Q) signal.

The default value is 0.

MaxEye DVB-S2 SG Set IQ Gain Imbalance.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Quadrature Skew.vi

This VI configures the value for Quadrature skew Property in degrees in the DVB-S2 Signal Generation handle. Quadrature Skew specifies the deviation in angle from 90 degrees between the in-phase (I) and quadrature-phase (Q) signals.

The default value for the Quadrature Skew is 0.

MaxEye DVB-S2 SG Set Quadrature Skew.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Frequency Offset.vi

This VI configures the value for the Frequency Offset property, in Hz in the DVB-S2 Signal Generation Handle. The toolkit applies frequency offset to the created waveform based on the value configured in this property. The applied frequency offset is relative to the signal generator's carrier frequency.

The default value is 0.

MaxEye DVB-S2 SG Set Frequency Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Clock Offset.vi

This VI configures the value for the Clock Offset property, in PPM in the DVB-S2 Signal Generation handle. The toolkit applies the clock offset to the generated waveform based on this value. The applied clock offset is relative to the the clock frequency of the signal generator.

The default value is 0.

MaxEye DVB-S2 SG Set Clock Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Get Waveform Size.vi

This VI returns the total Waveform Size of the complex waveform generated for the given configuration in samples to the DVB-S2 signal generation handle.

MaxEye DVB-S2 SG Get Waveform Size.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DVB-S2 SG Set Carrier Frequency.vi

This VI configures the centre frequency of the RF channel. It sets the Carrier Frequency used to receive the given DVB-S2 signal in Hertz.

MaxEye DVB-S2 SG Set Carrier Frequency.vi

MAXEYE TECHNOLOGIES Private Limited