MAXEYE DTMB Signal Generation Toolkit Help

The MAXEYE DTMB Signal generation toolkit contains VIs that can be used for generating signals with National Instruments hardware or generate signals in simulation mode as per the DTMB Standard GB 20600-2006. This document has information about the toolkit Labview API VIs to help engineers for programming.

____________________________________________________________________________________________________

For more information regarding this help please contact info@maxeyetech.com


MaxEye DTMB SG Initialize.vi

This VI creates MaxEye DTMB Generation Handle with the default values and passes the handle to the later VIs.

MaxEye DTMB SG Initialize.vi

MAXEYE TECHNOLOGIES Private Limited
Digital Video Toolkits - DTMB Signal Generation

For more details on this help, please write to us at
info@maxeyetech.com


MaxEye DTMB RFSG Create and Download Waveform.vi

This VI perfoms the following.

i. Checks the configuration parameters in the DTMB Signal Generation handle and returns an error if the configuration is not valid.
ii. Computes the waveform size, allocates on board memory space for writing waveform.
iii. Creates the DTMB waveform as per the configured parameters.
iv. Writes the created waveform in the RFSG on board memory.

MaxEye DTMB RFSG Create and Download Waveform.vi

MAXEYE TECHNOLOGIES Private Limited
Digital Video Toolkits - DTMB Signal Generation


MaxEye DTMB SG Create and Save Waveform.vi

This VI perfoms the following.

i. Checks the configuration parameters in the DTMB Signal Generation handle and returns an error if the configuration is not valid.
ii. Computes the waveform size and returns it to the user
iii. Creates the DTMB waveform as per the configured parameters.
iv. Writes the created waveform in the file as per the waveform file path location configured by the user

MaxEye DTMB SG Create and Save Waveform.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Read Waveform From File I8.vi

This VI reads the DTMB waveform from the given file location based on the value configured in the count input parameter. The number of bytes read from the file is equal to the value of the count. The data is read continuously from the file.

The default value of the count is 1.

MaxEye DTMB SG Read Waveform From File I8.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Number of System Subcarriers.vi

This VI configures the Number of System Subcarriers property used in the DTMB signal generation handle. The property value C=1 refers to single carrier signal generation mode and C=3780 refers to mutli carrier signal generation mode.

The default value is C=1 (Single Carrier Mode).

MaxEye DTMB SG Set Number of System Subcarriers.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Number of Super Frames.vi

This VI configures the Number of Super Frames to be generated in the DTMB signal generation handle. The default value is 1.

MaxEye DTMB SG Set Number of Super Frames.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Frame Header Mode.vi

This VI configures the Frame Header property in the DTMB signal generation handle. The valid values are 0 (Frame Header Mode 1), 1 (Frame Header Mode 2) and 2 (Frame Header Mode 3). The mode selection determines the length of the PN sequence and the number of frames per super frame.The length of the Frame Header are 420, 595 and 945 for Mode1, Mode2 and Mode3 respectively.The number of frames per super frames are 225, 216 and 200 for Mode 1, Mode 2 and Mode 3 respectively.

The default value is Mode 1.

MaxEye DTMB SG Set Frame Header Mode.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Modulation Scheme.vi

This VI configures Modulation Scheme in the DTMB signal generation handle. The valid ring values are 0 (4QAM NR), 1 (4QAM), 2 (16 QAM), 3 (32 QAM) and 4 (64 QAM). For 4QAM NR mapping refer to 4.4.3.6 of GB 20600-2006 DTMB standard.

The default value is 4QAM.

MaxEye DTMB SG Set Modulation Scheme.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Code Rate.vi

This VI configures Coding Rate property in the DTMB signal generation handle. The valid values are 0,1 and 2. The Code Rate selection determines the block length of data bits used for FEC Encoding and the number of Parity Check bits. The default value of the Code Rate is 0.

MaxEye DTMB SG Set Code Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Interleaver Mode.vi

This VI configures the Interleaver Mode property in the DTMB signal generation handle. The valid ring values are 0 and 1.The interleaver width remains same as 52 for both the modes. Interleaver depths are 240 and 720 for Mode1 and Mode2 respectively. This interleaving is done in the time domain on the complex symbols after bits to symbol constellation mapping for all the modulation schemes except 4QAM NR. For 4QAM NR interleaving is done at bit level before symbol mapping.

For more details refer to figure 7 of DTMB standard GB 20600-2006. The default value is 1.

MaxEye DTMB SG Set Interleaver Mode.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set PN Phase Change Enabled.vi

This VI configures the PN Phase Change Enabled property in the DTMB signal generation handle. The valid values are 0 (True) and 1 (False). This property is applicable only If the Frame Header Mode is set to 0 (Frame Header Mode 1) or 2 (Frame Header Mode 3). If this property is set to 1 (False) then the toolkit initializes the PN sequence generator for frame header generation only at the beginning of the super frame.

For more information about the Frame header generation refer to section 4.6.2 of DTMB standard GB 20600-2006.

The default value is Mode 0 (True).

MaxEye DTMB SG Set PN Phase Change Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Filter Length,Symbols.vi

This VI configures the length of the pulse shaping filter in the DTMB signal generation handle. The valid values are greater than 1.

The default value is 64 symbols.

MaxEye DTMB SG Set Filter Length,Symbols.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Headroom,dB.vi

This VI configures the Head room property in the DTMB signal generation handle. The toolkit uses this value for scaling the wave form. If the PAPR of the signal is higher than the Head Room value then the toollkit clips the signal.To avoid clipping the Head Room value should be higher than the PAPR of the signal.

The default value is 12 dB.

MaxEye DTMB SG Set Headroom,dB.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Waveform File Path.vi

The VI configures the file location for the Waveform File Path property in DTMB Signal Generation handle. The toolkit saves the generated waveform in the file when MaxEye DTMB RFSG Create and Save Waveform API VI is used for the wavefrom creation.

MaxEye DTMB SG Set Waveform File Path.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Oversampling Enabled.vi

This VI configures the Oversampling Enabled property in the DTMB Signal Generation handle. If this property is set to True then the toolkit resamples the generated signal based on the value configured by the user for the Output Sampling Rate property.

The valid values are True and False. The default value is False.

MaxEye DTMB SG Set Oversampling Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Output Sampling Rate.vi

This VI configures the Output Sampling Rate (Hz) property of the DTMB Signal Generation handle.
The toolkit resamples the generated signal to a sampling rate equal to the Output Sampling Rate only if the Over Sampling Enabled property is set to 1(True). If this value is zero then toolkit generates the signal at a default sampling rate which is in turn dependent on the Bandwidth.

MaxEye DTMB SG Set Output Sampling Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Output Waveform Sample Width.vi

This VI configures the Sample Width property in the DTMB Signal Generation handle. The toolkit uses this value only when MaxEye DTMB SG Create and Save Waveform API VI is used for storing the generated waveform in the file.

If the Sample Width property is set to 0(8-bit) the toolkit uses 8 bits for quantizing I and Q sample and if it is set to 1(16-bit) the toolkit uses 16 bits for quantizing the I and Q samples.

MaxEye DTMB SG Set Output Waveform Sample Width.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Get Channel Bitrate.vi

This VI returns the Channel Bitrate property in bits/second for the given input configuration to the DTMB signal generation handle.

The toolkit returns an error if the channel bitrate is lesser than the sum of the bitrate of all the MPEG2TS files.

MaxEye DTMB SG Get Channel Bitrate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Get MPEG2TS PIDs.vi

This VI returns the list of available PIDs from all the MPEG2 TS files used as a payload for generating the signal. This VI returns an empty array if the Payload Mode property is not set to MPEG2TS File(s).

MaxEye DTMB SG Get MPEG2TS PIDs.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Get Waveform Length.vi

This VI returns the total Waveform Size (in samples) of the complex waveform generated for the given configuration in samples to the DTMB signal generation handle.

MaxEye DTMB SG Get Waveform Length.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Close Handle.vi

This VI closes the DTMB Signal Generation handle and resources associated with it.

MaxEye DTMB SG Close Handle.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Payload Configuration.vi

This VI configures the Payload properties for the DTMB Signal generation handle. The help for the each of the payload property can be found in the proeprty specific API VIs. This API is used for configuring the multiple API properties using the payload cluster.

MaxEye Technologies Recommends to use property specific API VIs to avoid incompatibility issues with the Future release of this software.

MaxEye DTMB SG Set Payload Configuration.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Payload Mode.vi

This VI configures the Payload Mode property in the DTMB Signal Generation handle. The valid values for the Payload property are

PN Sequence - Specifies that the toolkit uses a Galois pseudonoise (PN) bit sequence with configurable order and seed. The seed is the initial state of the PN generator shift register.

User Defined Bits - Specifies that the toolkit repeats the user-supplied bit pattern to achieve the necessary payload length.

Test File - Specifies that the toolkit uses the data stored in the binary file as a payload for creating the waveform.

Test Pattern - Specifies that toolkit uses the value set in the Payload Test Pattern property as a payload for creating the waveform. The length of the Test Pattern is 8 bits. This value is the default.

MPEG2TS File(s) - Specifies that the toolkit uses the MPEG2 TS bitstream as a payload for creating the waveform. Use this payload mode for playing the video in the device under test.

MaxEye DTMB SG Set Payload Mode.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Number of MPEG2 TS Files.vi

This VI configures the MPEG2 TS Number of Files property in the DTMB Signal Generation handle. The toolkit combines the multiple TS files to a single TS bitstream based on the bitrate of the each TS file and the channel bitrate of the DTMB system.

The default value is 1.

MaxEye DTMB SG Set Number of MPEG2 TS Files.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set MPEG2 TS File Path.vi

The VI configures the file location for the MPEG2TS File Path property in DTMB Signal Generation handle for the selected TS File index. The toolkit ignores this property if the Payload Mode property value is set to other than MPEG2TS File(s) mode.

MaxEye DTMB SG Set MPEG2 TS File Path.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Payload File Path.vi

This VI configures the Payload File Path property in the DTMB Signal Generation handle. The toolkit reads the payload data from the binary file for generating the signal when the Payload Mode property is set to
Test File.

MaxEye DTMB SG Set Payload File Path.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Payload PN Order.vi

This VI configures the Payload PN Order property in the DTMB Signal Generation handle . The PN order specifies the order (length of memory) of the pseudorandom bit sequence (PRBS) generator. This property is applicable only when the Payload property is set to PN Sequence.

The default value for the PN Order property is 9.

MaxEye DTMB SG Set Payload PN Order.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Payload PN Seed.vi

This VI configures the Payload PN seed in the DTMB Signal Generation handle . This property is applicable only when the Payload property is set to PN Sequence.

The default value for the PN seed is BEEFBEEF.

MaxEye DTMB SG Set Payload PN Seed.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Payload Test Pattern.vi

This VI configures the Payload test pattern in the DTMB Signal Generation handle .This property is applicable only when the payload property is set to test pattern.The valid Test Patterns are All 1s,All 0 s,10101010,11110000

The default value for the Test Pattern is All 1s.

MaxEye DTMB SG Set Payload Test Pattern.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Payload User Defined Bits.vi

This VI configures the Payload User Defined Bits property in the DTMB Signal Generation handle .This property is applicable only when the Payload Mode property is set to User Defined Bits. The user defined bits should be array of 1s and 0s.

MaxEye DTMB SG Set Payload User Defined Bits.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Sync Insertion Enabled.vi

This VI configures the Sync Insertion Enabled property in the DTMB Generation handle. If this property is set to True and the Payload property is set to other than MPEG2TS File(s) then the toolkit inserts the MPEG2 TS bitstream header byte value (0x47) at the beginning of every 188 bytes.

The default value is False.

MaxEye DTMB SG Set Sync Insertion Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Impairments Enabled.vi

This VI configures the Impairments Enabled property in the DTMB Signal Generation handle. If this property is set to True then the toolkit adds the impairments to the generated signal as per the user configuration for the supported impairments.

The valid values are True and False. The default value is False.

MaxEye DTMB SG Set Impairments Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set AWGN Enabled.vi

This VI configures the AWGN Enabled property in the DTMB Signal Generation handle. If this property is set to True then the toolkit adds Additive White Gaussian Noise (AWGN) to the created waveform based on the value configured in the Carrier to Noise Ratio property.

The valid values are True and False. The default value is False.

MaxEye DTMB SG Set AWGN Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Carrier to Noise Ratio.vi

This VI configures the value for the Carrier to Noise ratio property, in dB in the DTMB Signal Generation handle. This value specifies the Carrier to Noise ratio of the generated signal.

The default value is 50dB.

MaxEye DTMB SG Set Carrier to Noise Ratio.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Frequency Offset.vi

This VI configures the value for the Frequency Offset property, in Hz in the DTMB Signal Generation Handle. The toolkit applies frequency offset to the created waveform based on the value configured in this property. The applied frequency offset is relative to the signal generator's carrier frequency.

The default value is 0.

MaxEye DTMB SG Set Frequency Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Clock Offset.vi

This VI configures the value for the Clock Offset property, in PPM in the DTMB Signal Generation handle. The toolkit applies the clock offset to the generated waveform based on this value. The applied clock offset is relative to the the clock frequency of the signal generator.

The default value is 0.

MaxEye DTMB SG Set Clock Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set I DC Offset.vi

This VI configures the I DC Offset, in % in the DTMB Signal Generation Handle. The toolkit adds the DC offset to the in-phase signal component (I) of the complex waveform as a percentage of the root mean square magnitude of the unaltered I signal.

The default value is 0.

MaxEye DTMB SG Set I DC Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Q DC Offset.vi

This VI configures the value for Q DC Offset property, in % in the DTMB Signal Generation Handle. The toolkit adds the DC offset to the quadrature-phase signal component (Q) of the complex waveform as a percentage of the root mean square magnitude of the unaltered Q signal.

The default value is 0.

MaxEye DTMB SG Set Q DC Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set IQ Gain Imbalance.vi

The VI configures the value for the IQ Gain Imbalance property, in dB in the DTMB Signal Generation handle. This value specifies the ratio, in dB, of the mean amplitude of the in-phase (I) signal to the mean amplitude of the quadrature-phase (Q) signal.

The default value is 0.

MaxEye DTMB SG Set IQ Gain Imbalance.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Quadrature Skew.vi

This VI configures the value for Quadrature skew Property in degrees in the DTMB Signal Generation handle. Quadrature Skew specifies the deviation in angle from 90 degrees between the in-phase (I) and quadrature-phase (Q) signals.

The default value for the Quadrature Skew is 0.

MaxEye DTMB SG Set Quadrature Skew.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Impairment Configuration.vi

This VI configures theImpairment properties for the DTMB Signal generation handle. The help for the each of the payload property can be found in the proeprty specific API VIs. This API is used for configuring the multiple API properties using the payload cluster.

MaxEye Technologies Recommends to use property specific API VIs to avoid incompatibility issues with the Future release of this software.

MaxEye DTMB SG Set Impairment Configuration.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DTMB SG Set Payload File Path in Layer.vi

This VI configures the Payload File Path property in the DTMB Signal Generation handle for the selected Layer Index. The valid values for the Layer Index is 0, 1 and 2.

The default value for Layer Index is 0.

MaxEye DTMB SG Set Payload File Path in Layer.vi

MAXEYE TECHNOLOGIES Private Limited