MAXEYE DAB/T-DMB Signal Analysis Toolkit Help

The MAXEYE DAB/T-DMB Signal analysis toolkit contains LabVIEW VIs to perform measurements on DAB/T-DMB signals that confirm ETSI standard EN 300401 version 1.4.1. Refer to the ETSI EN 300401 standard for the signal specifications and this document assumes that the user is familiar with the DAB/T-DMB standard specification. This document has information about the toolkit Labview API VIs to help engineers for programming.

____________________________________________________________________________________________________

For more information regarding this help please contact info@maxeyetech.com


MaxEye DAB SA Initialize.vi

Creates MaxEye DAB Signal Analysis Handle with the default values and passes the handle to the later VIs.

MaxEye DAB SA Initialize.vi

MAXEYE TECHNOLOGIES Private Limited
Digital Video Toolkits - DAB/T-DMB Signal Analysis

For more details on this help, please write to us at
info@maxeyetech.com


MaxEye DAB RFSA Configure Hardware.vi

This VI configures the following properties in the NI RFSA hardware,

1. For Demodulation Measurements

i. Configures the NI RFSA Acquisition Type to IQ or Spectrum Mode based on the measurement mode value configured by the user.
ii. Configures the NI RFSA Number of Records property to Number of Averages value configured by the user.
iii. Configures Number of Records Is Finite to TRUE.
iv. Configures the NI RFSA IQ Rate property to the reciprocal of the elementary period. The tool kit internally computes the elementary period based on the Transmission Mode value configured by the user.
v. Configures the NI RFSA trigger settings based on the PreTrigger Delay and Minimum Quite Time values.
vi. Configures the NI RSA Number of Samples property based on the Acquisition Length and IQ Rate.

2. Spectral Measurements

i. Configures the NI RFSA Acquisition Type to IQ or Spectrum Mode based on the measurement mode value configured by the user.
ii. Configures the NI RFSA Power Spectrum Units property to Volts Squared.
iii. Configures the NI RFSA Number of Averages property to Number of Averages value.
iv. Configures the NI RFSA Averaging Mode property to Averaging Mode value.

MaxEye DAB RFSA Configure Hardware.vi

MAXEYE TECHNOLOGIES Private Limited
Digital Video Toolkits - DAB/T-DMB Signal Analysis


MaxEye DAB RFSA Measure.vi

This VI perfoms the following.

i. Checks the configuration parameters in the DAB Signal Analysis handle and returns an error if the configuration is not valid.
ii. Configures the NI RFSA properties based on the user configuration. For more details refer MaxEye DAB RFSA Configure Hardware.vi documentation.
iii. Initiates the Acquisition by calling niRFSA Initiate.vi.
iv. Based on the measurement mode configured by the user, either niRFSA Fetch IQ.vi or niRFSA Read Power Spectrum.vi is used for acquiring the signal.
v. Performs Demodulation Measurements or Spectral Measurements based on the Measurement Mode.

MaxEye DAB RFSA Measure.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB USRP Measure.vi

This VI perfoms the following.

i. Checks the configuration parameters in the DAB Signal Analysis handle and returns an error if the configuration is not valid.
ii. Initiates the Acquisition by calling niUSRP Initiate.vi.
iv. The signal is acquired using niUSRP Fetch Rx Data.vi.
v. Performs Demodulation Measurements or Spectral Measurements based on the Measurement Mode.

MaxEye DAB USRP Measure.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Close Handle.vi

Closes the DAB Signal Analysis handle and resources associated with it.

MaxEye DAB SA Close Handle.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set Transmission Mode.vi

Configures the Transmission Mode property for the DAB Signal analysis handle.

The valid enum values for Transmission Mode are 0( Mode I ), 1( Mode II ) , 2(Mode III ) and 3( Mode IV ). The default value is set to 0( Mode I).

MaxEye DAB SA Set Transmission Mode.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set Measurement Mode.vi

Configures the Measurement Mode property of the DAB Signal Analysis handle.

The valid enum values of Measurement Mode are
0 (Demodulation Measurements)
1 (Spectral Measurements)

MaxEye DAB SA Set Measurement Mode.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set Number of Averages.vi

Configures the Number of Averages property of the DAB Signal Analysis handle. The measurement results are averaged over the number specified by Number of Averages.

MaxEye DAB SA Set Number of Averages.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set Acquisition Length.vi

Sets the Acquisition Length property of the DAB Signal Analysis handle. The toolkit reads the number of samples equivalent to the Acquisition Length. The minimum Acquisition Length in seconds should be equal to atleast one frame plus the Measurement Number of Symbols.

MaxEye DAB SA Set Acquisition Length.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set Measurement No of Symbols.vi

Configures the Measurement Number of Symbols to be used for DAB Signal Analysis handle.

The valid values for this property should be divisible by 5 and the values can range between 5 to 75. The default value is 10 symbols. The toolkit excludes the phase reference symbol for EVM (MER) computations. Therefore the maximum value is 75.

MaxEye DAB SA Set Measurement No of Symbols.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set Channel Estimation Enabled.vi

Configures the Channel Estimation Enabled property of the DAB Signal Analysis handle. The valid enum values for this property is 0 (FALSE) or 1 (TRUE).

MaxEye DAB SA Set Channel Estimation Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set Minimum Quiet Time.vi

Sets the Minimum Quite Time property of the DAB Signal Analysis handle. This value specifies the minimum time below the trigger value during which the signal must remain off, in order to trigger.

MaxEye DAB SA Set Minimum Quiet Time.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set PreTrigger Delay.vi

Configure the PreTrigger Delay property of the DAB Signal Analysis handle.

MaxEye DAB SA Set PreTrigger Delay.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set FFT Window Type.vi

Configures the FFT Window Type property of the DAB Signal Analysis handle. FFT Window Type is the time-domain window to apply to the time signal.

The valid enum values of FFT Window Types are,
0 (Rectangle)
1 (Hanning (default))
2 (Hamming)
3 (Blackman-Harris)
4 (Exact Blackman)
5 (Blackman)
6 (Flat Top)
7 (4 Term B-Harris)
8 (7 Term B-Harris)
9 (Low Sidelobe)
11 (Blackman Nutall)
30 (Triangle)
31 (Bartlett-Hanning)
32 (Bohman)
33 (Parzen)
34 (Welch)
60 (Kaiser)
61 (Dolph-Chebyshev)
62 (Gaussian)

MaxEye DAB SA Set FFT Window Type.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set Center Channel Frequency.vi

Configures the Center Channel Frequency property of the DAB Signal Analysis handle.

MaxEye DAB SA Set Center Channel Frequency.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set Center Channel Bandwidth.vi

Configures the Center Channel Bandwidth property of the DAB Signal Analysis handle.
Specifies the frequency range for each channel, in Hz

MaxEye DAB SA Set Center Channel Bandwidth.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set ACP Frequency Offsets.vi

Configures the Adjacent Channel Frequency Offsets property of the DAB Signal Analysis handle, in Hz.

Adjacent Channel Frequency Offsets specifies the distance from the center frequency of the main channel to the center frequency of the adjacent channels.

MaxEye DAB SA Set ACP Frequency Offsets.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set ACP Bandwidths.vi

Configures the Adjacent Channel Bandwidths property of the DAB Signal Analysis handle.

Adjacent Channel Bandwidth specifies the frequency range of each channel, in Hz.

MaxEye DAB SA Set ACP Bandwidths.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set SEM Frequency Offsets.vi

Configures the Spectral Emission Mask (SEM) Frequency Offsets property of the DAB Signal Analysis Handle. The SEM Frequency Offsets specifies the offset from the center frequency.

The toolkit uses this property along with the SEM Power Offsets property to create the Spectral Emission Mask.

MaxEye DAB SA Set SEM Frequency Offsets.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set SEM Power Offsets.vi

Configures the Spectral Emission Mask (SEM) Power Offset property of the DAB Signal Analysis handle in dB. The Power Offset levels corresponds to the each frequency offset points specified by SEM Frequency Offsets Property. The Power Offset is relative to the power level specified by the SEM Reference Power Level Type property.

The toolkit uses this property along with SEM Frequency Offsets Property to create the Spectral Emission Mask.

MaxEye DAB SA Set SEM Power Offsets.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set SEM Reference Level Type.vi

Configures the Spectral Emission Mask (SEM) Reference Level Type property of the DAB Signal Analysis handle.

The toolkit uses this property to compute the Spectral Emission Mask.

The valid enum values are
0 (Peak Power)
1 (Total Channel Power)
2 (User Defined Power Level)

MaxEye DAB SA Set SEM Reference Level Type.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set SEM Reference Power Level.vi

This VI configures the Spectral Emission Mask (SEM) Reference Power Level property of the DAB signal Analysis handle. The toolkit uses this property when the SEM Reference Level Type property is set to User Defined Power Level.

The SEM Reference Power Level and SEM Power Offsets are used to compute the the absolute power levels for each SEM frequency offset points.
The toolkit uses this property to create the Spectral Emission Mask.

MaxEye DAB SA Set SEM Reference Power Level.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set Averaging Mode.vi

Configures the Averaging Mode property of the DAB Signal Analysis handle. The Averaging mode specifies the type of averaging method used for spectral acquisition. This property is applicable only if the Measurement Mode is Spectral Measurements.

The valid enum values for Averaging mode are
0 (No Averaging)
1 (Vector Averaging)
2 (RMS Averaging)
3 (Peak Hold)

MaxEye DAB SA Set Averaging Mode.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Set Weighting Mode.vi

Configures the Weighting mode property of the DAB Signal analysis handle. This property is applicable only if the Measurement Mode is Spectral Measurements.

The valid enum values are
0 (Linear)
1 (Exponential)
This property is applicable only for Spectral Measurements.

MaxEye DAB SA Set Weighting Mode.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get RMS EVM in dB.vi

Returns the measured RMS Error Vector Magnitude (EVM) in dB. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DAB SA Get RMS EVM in dB.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get RMS EVM in percentage.vi

Returns the measured RMS Error Vector Magnitude (EVM) in percentage. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DAB SA Get RMS EVM in percentage.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Peak EVM in dB.vi

Returns the measured Peak Error Vector Magnitude (EVM) in dB. The ratio of error vector to the ideal symbol vector for a particular symbol and subcarrier gives the instantaneous EVM. Peak EVM is the maximum EVM across all symbols and subcarriers. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

MaxEye DAB SA Get Peak EVM in dB.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Peak EVM in percentage.vi

Returns the measured Peak Error Vector Magnitude (EVM) in percentage. The ratio of error vector to the ideal symbol vector for a particular symbol and subcarrier gives the instantaneous EVM. Peak EVM is the maximum EVM across all symbols and subcarriers. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

MaxEye DAB SA Get Peak EVM in percentage.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Peak EVM Subcarrier Position.vi

Returns the active subcarrier number corresponding to the Peak Error Vector Magnitude (EVM).
This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

MaxEye DAB SA Get Peak EVM Subcarrier Position.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Peak EVM Symbol Position.vi

Returns the symbol number corresponding to the Peak Error Vector Magnitude (EVM).
This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

MaxEye DAB SA Get Peak EVM Symbol Position.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get MER (dB).vi

Returns the measured Modulation Error Ratio (MER) in dB. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DAB SA Get MER (dB).vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Peak MER (dB).vi

Returns the measured Peak Modulation Error Ratio (MER) in dB. The ratio of ideal symbol vector to error vector for a particular symbol and subcarrier gives the instantaneous MER. Peak MER is the maximum MER across all symbols and subcarriers. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

MaxEye DAB SA Get Peak MER (dB).vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Frequency Offset.vi

Returns the average Frequency Offset in Hz. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DAB SA Get Frequency Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Clock Offset.vi

Returns the Clock Offset measured in PPM. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

MaxEye DAB SA Get Clock Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Magnitude Error.vi

Returns the measured Magnitude Error, in dB. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DAB SA Get Magnitude Error.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Phase Error (deg).vi

Returns the measured Phase Error in degrees. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DAB SA Get Phase Error (deg).vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get IQ Gain Imbalance.vi

Returns the measured IQ Gain Imbalance value, in dB. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DAB SA Get IQ Gain Imbalance.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get IQ Offset.vi

Returns the measured IQ Offset value, in dB. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DAB SA Get IQ Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Quadrature Skew.vi

Returns the Quadrature skew in degrees. Quadrature Skew specifies the deviation in angle from 90 degrees between the in-phase (I) and quadrature-phase (Q) signals. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit averages this measurement over the number of acquisitions specified by the Number of Averages value.

MaxEye DAB SA Get Quadrature Skew.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Average Power.vi

Returns the average power of the received signal in dBm. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

MaxEye DAB SA Get Average Power.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Peak Power.vi

Returns the measured peak power of the received signal, in dBm. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

The toolkit calculates peak hold averaging over the number of acquisitions specified by the Number of Averages value.

MaxEye DAB SA Get Peak Power.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Constellation Graph.vi

Returns the Constellation trace. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.
The returned array needs to be connected to XY graph to view the constellation points.

MaxEye DAB SA Get Constellation Graph.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Channel Frequency Response.vi

Returns the Channel Frequency Response (magnitude response) trace. This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements and Channel Estimation Enabled property is set to TRUE.

MaxEye DAB SA Get Channel Frequency Response.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get EVM Vs Subcarriers.vi

Returns a 2-D array of Error Vector Magnituce (EVM) values. The first dimension represents the Measurement Number of Symbols and second dimension represents the number of active subcarriers. The returned 2-D array needs to be connected to a waveform graph to visualize the EVM Vs Subcarriers.
If All Symbols control is enabled this VI returns EVM Vs Subcarriers for all symbols. if All Symbols control is not selected then the VI returns only EVM Vs Subcarrier values for a particular symbol specified in the Symbol Number control.

This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

MaxEye DAB SA Get EVM Vs Subcarriers.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get EVM Vs Symbols.vi

Returns a 2-D array of Error Vector Magnitude (EVM) values. The first dimension represents the number of active subcarriers and second dimension represents the Measurement Number of Symbols. The returned 2-D array needs to be connected to a waveform graph to visualize the EVM Vs Symbols.
If All Subcarrier control is enabled this VI returns EVM Vs Symbols for all subcarriers. if All Subcarrier control is not selected then the VI returns only EVM Vs Symbols values for a particular subcarrier specified in the Subcarrier Number control.

This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

MaxEye DAB SA Get EVM Vs Symbols.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get MER Vs Subcarriers.vi

Returns a 2-D array of Modulation Error Ratio (MER) values. The first dimension represents the Measurement Number of Symbols and second dimension represents the number of active subcarriers. The returned 2-D array needs to be connected to a waveform graph to visualize the MER Vs Subcarriers.
If All Symbols control is enabled this VI returns MER Vs Subcarriers for all symbols. if All Symbols control is not selected then the VI returns only MER Vs Subcarrier values for a particular symbol specified in the Symbol Number control.

This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

MaxEye DAB SA Get MER Vs Subcarriers.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get MER Vs Symbols.vi

Returns a 2-D array of Modulation Error Ratio(MER) values. The first dimension represents the number of active subcarriers and second dimension represents the Measurement Number of Symbols. The returned 2-D array needs to be connected to a waveform graph to visualize the MER Vs Symbols.
If All Subcarriers control is enabled this VI returns MER Vs Symbols for all subcarriers. if All Subcarriers control is not selected then the VI returns only MER Vs Symbols values for a particular subcarrier specified in the Subcarrier Number control.

This measurement is applicable only if the Measurement Mode is set to Demodulation Measurements.

MaxEye DAB SA Get MER Vs Symbols.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Channel Power.vi

Returns the channel power in dBm, based on the Center Channel Frequency and Center Channel Bandwidth property configured by the user. This measurement is applicable only if the Measurement Mode is set to Spectral Measurements.

MaxEye DAB SA Get Channel Power.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Adjacent Channel Powers.vi

Returns the power in dBm, in the adjacent channels based on the ACP Frequency Offsets and ACP Bandwidths property configured by the user. This measurement is applicable only if the Measurement Mode is set to Spectral Measurements.

MaxEye DAB SA Get Adjacent Channel Powers.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Spectral Mask Margin.vi

Returns the Spectral Mask Margin in dB. Spectral mask margin is the worst difference between the spectral mask and the measured Power Spectrum. This measurement is applicable only if the Measurement Mode is set to Spectral Measurements.

The toolkit averages the power spectrum over the number of acquisitions specified by the Number of Averages value. The measurement is performed on the average power spectrum.

MaxEye DAB SA Get Spectral Mask Margin.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye DAB SA Get Spectral Mask Trace.vi

This VI returns the Spectral Mask Trace.

Spectral Mask Trace is a cluster consisting of 3 elements.
1. The first element (f0) returns the initial frequency of the power spectrum.
2. The second element (df) returns the frequency interval between the data points of the power spectrum
3. The third element (y) is a 2D array. The first row returns array of Spectral Emission Mask values as per the SEM Power Offsets and SEM Frequency Offset values configured by the user. The second row returns the Power Spectrum in dBm.

This measurement is applicable only if the Measurement Mode is set to Spectral Measurements.

The toolkit averages the power spectrum over the number of acquisitions specified by the Number of Averages value. The measurement is performed on the average power spectrum.

MaxEye DAB SA Get Spectral Mask Trace.vi

MAXEYE TECHNOLOGIES Private Limited